Bug 816575 - backing clusters of the image convert with -B are allocated when they shouldn't
backing clusters of the image convert with -B are allocated when they shouldn't
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 08:40 EDT by Suqin Huang
Modified: 2013-02-21 02:34 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.306.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:34:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2012-04-26 08:40:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.278.el6.x86_64

How reproducible:
100%


Steps to Reproduce:
1. get qemu-iotests from 
http://git.kernel.org/?p=linux/kernel/git/hch/qemu-iotests.git
2. ./check -qcow2 019
3.
  
Actual results:

 Checking if backing clusters are allocated when they shouldn't
 
-qemu-io> 0/128 sectors allocated at offset 1 MiB
-qemu-io> qemu-io> 0/128 sectors allocated at offset 4.001 GiB
+qemu-io> 128/128 sectors allocated at offset 1 MiB
+qemu-io> qemu-io> 128/128 sectors allocated at offset 4.001 GiB
 qemu-io> Reading

Expected results:


Additional info:
Comment 3 RHEL Product and Program Management 2012-07-10 02:40:10 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 22:06:44 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 8 Shaolong Hu 2012-11-29 04:48:39 EST
Verified on qemu-kvm-rhev-0.12.1.2-2.334.el6.x86_64

[root@localhost qemu-iotests]# ./check -qcow2 019
QEMU          -- /usr/bin/qemu
QEMU_IMG      -- /usr/bin/qemu-img
QEMU_IO       -- /usr/bin/qemu-io 
IMGFMT        -- qcow2
IMGPROTO      -- file
PLATFORM      -- Linux/x86_64 localhost 2.6.32-338.el6.x86_64

019	
Passed all 1 tests
Comment 10 errata-xmlrpc 2013-02-21 02:34:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.