This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 816579 - [virt-viewer]usbredirection can't worked when use ssh connect to guest
[virt-viewer]usbredirection can't worked when use ssh connect to guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 08:53 EDT by zhe peng
Modified: 2012-10-16 11:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 11:09:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
--spice-debug log file (144.58 KB, text/plain)
2012-04-26 22:21 EDT, zhe peng
no flags Details
guest xml file (3.99 KB, text/plain)
2012-04-26 22:21 EDT, zhe peng
no flags Details

  None (edit)
Description zhe peng 2012-04-26 08:53:46 EDT
Description of problem:
 when use ssh connect guest ,the usb-device redirection can't worked.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-14.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
spice-gtk-0.11-8.el6.x86_64
spice-server-0.10.1-5.el6.x86_64
usbredir-0.4.3-1.el6.x86_64
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1: prepare two host
2: config ssh between the two machine
in one box:
#ssh-keygen
#ssh-copy-id -i /root/.ssh/id_rsa.pub root@$remote_IP
3: prepare a windows guest with usb-redirection support
3.1 Download the .cfg file to /etc/qemu:
# wget http://cgit.freedesktop.org/spice/qemu/plain/docs/ich9-ehci-uhci.cfg

3.2 config guest xml :
<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>
And add the following lines at the end, above the "</domain>" line:
  <qemu:commandline>
     <qemu:arg value='-readconfig'/>
     <qemu:arg value='/etc/qemu/ich9-ehci-uhci.cfg'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev1'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev1,id=usbredirdev1,bus=ehci.0,debug=3'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev2'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev2,id=usbredirdev2,bus=ehci.0,debug=3'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev3'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev3,id=usbredirdev3,bus=ehci.0,debug=3'/>
  </qemu:commandline>
4: make sure in guest ,the Red hat usb redirector service started.
5: in another host , use ssh to connect the guest
# virt-viewer -c qemu+ssh://10.66.6.166/system win7_64
6: in virt-viewer, click "File"->"USB Device selection"

Actual results:
the device can't mount to the guest.

Expected results:
the usb device can redirect to the guest.

Additional info:
if not use ssh connection, the usb-device can worked well.
in this ssh env. ,the smartcard can worked well.
Comment 2 Daniel Berrange 2012-04-26 10:05:02 EDT
Can you repeat using this command:

# virt-viewer --spice-debug --debug -c qemu+ssh://10.66.6.166/system win7_64

and attach the resulting debug info to this bug
Comment 3 zhe peng 2012-04-26 22:21:15 EDT
Created attachment 580619 [details]
--spice-debug log file
Comment 4 zhe peng 2012-04-26 22:21:59 EDT
Created attachment 580620 [details]
guest xml file
Comment 5 RHEL Product and Program Management 2012-05-03 01:00:31 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-07-10 02:58:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 22:01:21 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 10 Daniel Berrange 2012-10-16 11:09:52 EDT
We're not intending to fix this because it only happens with the legacy closed source USB redirection service.

Note You need to log in before you can comment on or make changes to this bug.