Bug 816738 - cgsnapshot saves tabs but cgconfigparser doesn't accept them.
cgsnapshot saves tabs but cgconfigparser doesn't accept them.
Status: CLOSED DUPLICATE of bug 788580
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Schiffer
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 16:25 EDT by Edward
Modified: 2012-04-27 09:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 05:29:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward 2012-04-26 16:25:31 EDT
Description of problem: Using cgsnapshot to save a configuration that includes blkio.throttle.write_bps_device will result in a line in the cgconfig.conf like: 

blkio.throttle.write_bps_device="8:0    10485769";

Between the 8:0 and the 10485769 is a tab.  cgconfig will complain that it can't parse this file.  Replacing that tab with a space corrects the issue.

Version-Release number of selected component (if applicable):
x86_64 0.37 3.el6 (This is actually CentOS version)

How reproducible: Very


Steps to Reproduce:
1. Start with a cgconfig that uses blkio
2. echo "8:0 10485769" > blkio.throttle.write_bps_device 
3. cgsnapshot -s  > /etc/cgconfig.conf 
4. service cgconfig restart

Actual results:
[root@air /]# service cgconfig restart                                                                                                                                                                               
Stopping cgconfig service:                                 [  OK  ]
Starting cgconfig service: Loading configuration file /etc/cgconfig.conf failed
Value setting does not succeed
Failed to parse /etc/cgconfig.conf                         [FAILED]

Expected results:
This should result in a successful restart.

Additional info:
Comment 2 Jan Safranek 2012-04-27 05:29:37 EDT

*** This bug has been marked as a duplicate of bug 788580 ***
Comment 3 Edward 2012-04-27 09:22:59 EDT
Strange.... before entering this bug, I searched for cgsnapshot and only bug 676700 and bug 647107 came up.  Now, of course, I search and can see bug 788580.  Sorry for the trouble!
Comment 4 Jan Safranek 2012-04-27 09:37:27 EDT
No problem, bug 788580 has limited visibility (dunno why), now you are on cc: there you can actually see it.

Note You need to log in before you can comment on or make changes to this bug.