Bug 816748 - virt-manager throws an internal error when trying to create new virtual machine
virt-manager throws an internal error when trying to create new virtual machine
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 17:02 EDT by Jared Smith
Modified: 2012-06-06 16:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 16:05:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2012-04-26 17:02:13 EDT
Description of problem:

virt-manager throws an internal error when trying to create a new virtual machine.

I get the following message: 

Unable to complete install: 'internal error Process exited while reading console log output: char device redirected to /dev/pts/3
Could not allocate dynamic translator buffer
'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1911, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1239, in start_install
    noboot)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1307, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2397, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/3
Could not allocate dynamic translator buffer

Version-Release number of selected component (if applicable):

virt-manager-0.9.1-2.fc17.noarch
qemu-kvm-1.0-17.fc17.x86_64
libvirt-0.9.11-1.fc17.x86_64


How reproducible:

Very

Steps to Reproduce:
1.  Start virt-manager
2.  Create a new VM
3.  See the error message
  
Actual results:

Pasted above.

Expected results:

A newly created VM

Additional info:
Comment 1 Jared Smith 2012-04-26 17:44:06 EDT
Turns out this was user error on my part -- I didn't have the virtualization extensions turned on in my BIOS.  (Now I feel like an idiot.)

It seems I'm not the only person who has encountered this issue, though.  Would it be possible to have virt-manager probe for the processor extensions, and give a better warning message if it doesn't find them enabled?
Comment 2 Cole Robinson 2012-06-06 16:05:57 EDT
Hmm, we should already be detecting this situation fairly well, and warn about it up front in the New VM wizard.

Jared, if you feel inclined to test, please turn off virt extensions, reboot, and provide the following info:

dmesg
sudo virsh --connect qemu:///system capabilities
cat /proc/cpuinfo

And also the full

/var/log/libvirt/qemu/$vmname.log

After the failed guest creation.

Closing as WORKSFORME until then.

Note You need to log in before you can comment on or make changes to this bug.