Bug 816808 - Consumer unbind with i18n repo id succeeds with no error in the log but repo is not actually deleted from pulp.repo
Consumer unbind with i18n repo id succeeds with no error in the log but repo ...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: Sprint 35
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 00:41 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 10:13:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2012-04-27 00:41:12 EDT
Description of problem:
$ pulp-admin consumer bind --repoid Brasília --id consumer1
Successfully subscribed consumer [consumer1] to repo [Brasília]

On consumer - 

$ cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#

[Brasília]
name = Brasília
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://localhost/pulp/repos/repos/pulp/pulp/dev/testing/fedora-15/x86_64


$ pulp-admin consumer unbind --repoid Brasília --id consumer1
Successfully unsubscribed consumer [consumer1] from repo [Brasília]


$ cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#

[Brasília]
name = Brasília
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://localhost/pulp/repos/repos/pulp/pulp/dev/testing/fedora-15/x86_64


Same operation if conducted using pulp-consumer succeeds - 

$ pulp-consumer consumer unbind --repoid Brasília
Successfully unsubscribed consumer [consumer1] from repo [Brasília]

$ cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#
Comment 1 Sayli Karmarkar 2012-04-27 00:47:33 EDT
Fixed - 

commit c94c28b4179bb13bfed637f30c9ff241b785866e
Author: Sayli Karmarkar <skarmark@redhat.com>
Date:   Thu Apr 26 21:45:05 2012 -0700

    816808 - fixing consumer unbind through goferplugin failing to delete repo from pulp.repo file due to wrong encoding for i18n repo ids

$ pulp-admin consumer bind --repoid Brasília --id consumer1Successfully subscribed consumer [consumer1] to repo [Brasília]

$ cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#

[Brasília]
name = Brasília
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://localhost/pulp/repos/repos/pulp/pulp/dev/testing/fedora-15/x86_64

$ pulp-admin consumer unbind --repoid Brasília --id consumer1Successfully unsubscribed consumer [consumer1] from repo [Brasília]

$ cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#
Comment 2 Jeff Ortel 2012-04-30 10:42:23 EDT
build: 1.1.6
Comment 3 Preethi Thomas 2012-05-01 15:07:34 EDT
verified

[root@pulp-v1-1-server ~]# rpm -q pulp
pulp-1.1.6-1.fc16.noarch

[root@pulp-client ~]# rpm -q pulp-consumer
pulp-consumer-1.1.6-1.el6.noarch

[root@pulp-v1-1-server ~]# pulp-admin consumer bind --id=pulp-client --repoid=Brasília
Successfully subscribed consumer [pulp-client] to repo [Brasília]

[root@pulp-client ~]# cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#

[Brasília]
name = Brasília
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://pulp-v1-1-server.usersys.redhat.com/pulp/repos/repos/pulp/pulp/v1/testing/fedora-16/x86_64[root@pulp-client ~]# 
[root@pulp-client ~]# 

[root@pulp-v1-1-server ~]# pulp-admin consumer unbind --id=pulp-client --repoid=Brasília
Successfully unsubscribed consumer [pulp-client] from repo [Brasília]

[root@pulp-client ~]# cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#
[root@pulp-client ~]# 
[root@pulp-v1-1-server ~]# pulp-admin consumergroup bind --id=grp1 --repoid=Brasília
Successfully subscribed consumer group [grp1] to repo [Brasília]

[root@pulp-v1-1-server ~]# 


[root@pulp-client ~]# cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#

[Brasília]
name = Brasília
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://pulp-v1-1-server.usersys.redhat.com/pulp/repos/repos/pulp/pulp/v1/testing/fedora-16/x86_64[root@pulp-client ~]# 
[root@pulp-v1-1-server ~]# pulp-admin consumergroup unbind --id=grp1 --repoid=Brasília
Successfully unsubscribed consumer group [grp1] from repo [Brasília]

[root@pulp-v1-1-server ~]# 
[root@pulp-client ~]# cat /etc/yum.repos.d/pulp.repo 
#
# Pulp Repositories
# Managed by Pulp client
#
Comment 4 Preethi Thomas 2012-05-25 10:13:44 EDT
Pulp v1.1 Release

Note You need to log in before you can comment on or make changes to this bug.