Bug 816872 - [3.3.0qa38] Perl search and replace script returns zero byte file
Summary: [3.3.0qa38] Perl search and replace script returns zero byte file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: write-behind
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Raghavendra G
QA Contact: Anush Shetty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 08:39 UTC by Anush Shetty
Modified: 2013-07-24 17:49 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-24 17:49:44 UTC
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anush Shetty 2012-04-27 08:39:39 UTC
Description of problem: With just write-behind and md-cache enabled, the perl search and replace text script returned zero byte file. I saw this only once and was not able to reproduce it again.


Version-Release number of selected component (if applicable): 3.3.0qa38


How reproducible: Saw this only once


Steps to Reproduce:
1. echo 'test' > /mnt/gluster/dot
2. Run the perl script in a loop - 
      while true; do perl -i -pe 's/test/test/' /mnt/gluster/dot;done
3. Read the file from another screen
      while true; do cat /mnt/gluster/dot; done;
  
Actual results:

The file became zero-bytes

Comment 1 Amar Tumballi 2012-05-25 16:09:25 UTC
Taking this off the 3.3.0 blocker list as we couldn't reproduce the issue after it was seen for the first time.

Comment 2 Amar Tumballi 2012-12-21 10:14:03 UTC
not seen this in any of our recent testing (ie, in last 7 months). Will be reducing the priority of the bug, please update if its found again, will be bumping up the version.

Comment 3 Amar Tumballi 2013-02-18 04:47:45 UTC
with few changes in quick-read translator, this should no more be an issue with 3.4.0 branch. Marking it modified.


Note You need to log in before you can comment on or make changes to this bug.