Bug 816874 - import shows black areas where windows operlap
import shows black areas where windows operlap
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ImageMagick (Show other bugs)
6.0
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Horak
Desktop QE
: Patch
Depends On:
Blocks: 1172231 1269194
  Show dependency treegraph
 
Reported: 2012-04-27 04:41 EDT by mad
Modified: 2017-04-20 15:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-20 15:44:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example screenshot with black areas (52.92 KB, image/png)
2012-04-27 04:41 EDT, mad
no flags Details

  None (edit)
Description mad 2012-04-27 04:41:16 EDT
Created attachment 580674 [details]
Example screenshot with black areas

Description of problem:

When creating a snapshot with import from ImageMagick, there appear black areas where windows overlap.

Version-Release number of selected component (if applicable):

6.5.4-7

How reproducible:

Always.

Steps to Reproduce:
1. Start a program (firefox, terminal, ...)
2. Open a terminal window. Move the window that it overlaps the first window.
3. Execute import e.g.: 

/usr/bin/import -pause 5 -silent -frame -colors 16 -window root -page B5'>'+35+35 test.jpg

4. Check the screenshot.
  
Actual results:

A screenshot which is black where windows overlap.

Expected results:

A screenshot without black areas.

Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 04:15:48 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 19:24:34 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-09-07 01:31:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 mad 2012-09-26 04:01:49 EDT
The bug was also found in Debian and fixed there. Could you please consider fixing this bug in RHEL, too.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546773
Comment 6 Olivier Fourdan 2012-09-26 04:46:10 EDT
Note, according to this link, the problem is with Xorg's driver, not ImageMagick, which would explain why I fail to reproduce here.

Note You need to log in before you can comment on or make changes to this bug.