Bug 817003 - Subscribing to CloudForms enables multiple project repos (one that isn't a product)
Subscribing to CloudForms enables multiple project repos (one that isn't a pr...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity low (vote)
: Unspecified
: --
Assigned To: Jay Greguske
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 08:21 EDT by James Laska
Modified: 2013-09-02 03:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-04-27 08:21:32 EDT
Description of problem:

WHen subscribing to CloudForms Beta using 'subscription-manager', 3 repositories are enabled by default:
 * CloudForms Application Engine (non-existent product)
 * CloudForms Cloud Engine
 * CloudForms System Engine

Since we don't support installing Cloud and System on the same system, we shouldn't enable the repos by default.  Additionally, we shouldn't enable Application Engine if it doesn't exist.

How reproducible:
 * Easy, use rhsm

Steps to Reproduce:
1. List available subscriptions
> subscription-manager list --available

2. Examine list of currently enabled repositories
> # yum repolist enabled
> repo id                         repo name                                     status
> rhel-6-server-cf-tools-1-rpms   Red Hat CloudForms Tools for RHEL 6 (RPMs)    0
> rhel-6-server-rpms              Red Hat Enterprise Linux 6 Server (RPMs)      7,104

3. Subscribe to CloudForms (or Beta)
> # subscription-manager subscribe --pool 8a9bf98636ea99cb0136f03c0fa037ed

4. Examine list of newly enabled repos

  
Actual results:

> # subscription-manager list --available
> +-------------------------------------------+
>     Available Subscriptions
> +-------------------------------------------+
> 
> <snip>
> 
> ProductName:            CloudForms Beta
> ProductId:              MCT2538
> PoolId:                 8a9bf98636ea99cb0136f03c0fa037ed
> Quantity:               2500
> Multi-Entitlement:      No
> Expires:                06/23/2012
> MachineType:            physical
> 
> <snip>
> 
> # subscription-manager subscribe --pool 8a9bf98636ea99cb0136f03c0fa037ed
> Successfully subscribed the system to Pool 8a9bf98636ea99cb0136f03c0fa037ed
> 
> # yum repolist enabled
> repo id                         repo name                                     status
> rhel-6-server-cf-ae-1-rpms      Red Hat CloudForms Application Engine (RPMs)  0
> rhel-6-server-cf-ce-1-rpms      Red Hat CloudForms Cloud Engine (RPMs)        0
> rhel-6-server-cf-se-1-rpms      Red Hat CloudForms System Engine (RPMs)       0
> rhel-6-server-cf-tools-1-rpms   Red Hat CloudForms Tools for RHEL 6 (RPMs)    0
> rhel-6-server-rpms              Red Hat Enterprise Linux 6 Server (RPMs)      7,104
> repolist: 7,104

Expected results:

Don't enable any repos.  The documentation for RHN classic recommends enabling specific repos.  This behavior should match for RHSM.

> # yum repolist enabled
> repo id                         repo name                                     status
> rhel-6-server-cf-tools-1-rpms   Red Hat CloudForms Tools for RHEL 6 (RPMs)    0
> rhel-6-server-rpms              Red Hat Enterprise Linux 6 Server (RPMs)      7,104
> repolist: 7,104
Comment 1 James Laska 2012-05-01 10:16:30 EDT
VERIFIED ...
 1) cf-ae is no longer available
 2) cf-se and cf-ce are no longer enabled by default

See "/CloudForms/Installation/SystemEngine" step of https://beaker.engineering.redhat.com/jobs/226083
Comment 3 Mike McCune 2013-08-16 14:03:30 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.