Bug 817079 - Bug in tar-1.23-3.el6.x86_64 rpm
Bug in tar-1.23-3.el6.x86_64 rpm
Status: CLOSED DUPLICATE of bug 698212
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar (Show other bugs)
6.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 11:33 EDT by Kamal Maiti
Modified: 2012-06-13 01:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL 6
Last Closed: 2012-04-28 03:56:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamal Maiti 2012-04-27 11:33:17 EDT
Description of problem:

We are facing issue with tar command with --remove-files option and it is not working with tar-1.23-3.el6

Version-Release number of selected component (if applicable):

tar-1.23-3.el6

How reproducible:

1. touch original ; ln -s original symlink ;
2. cd ..
3. tar -zcf test.gz test --remove-files
Cannot rmdir: Directory not empty
tar: Exiting with failure status due to previous errors
  
Actual results:
Cannot rmdir: Directory not empty

Expected results:
No error

Additional info:

This bug is fixed in 1.26 version. I tested it and it worked fine.
Comment 2 Ondrej Vasik 2012-04-28 03:56:15 EDT
I believe this bug report is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=698212 and is fixed in current tar build ( tar-1.23-7.el6 ) available in RHEL-6.3 beta .

*** This bug has been marked as a duplicate of bug 698212 ***

Note You need to log in before you can comment on or make changes to this bug.