Bug 817127 - print dialog has multiple deficiencies
print dialog has multiple deficiencies
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 14:55 EDT by John Griffiths
Modified: 2012-04-28 01:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 01:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 49230 None None None Never

  None (edit)
Description John Griffiths 2012-04-27 14:55:59 EDT
Description of problem:
There are numerous deficiencies in the print dialog.

Version-Release number of selected component (if applicable):
libreoffice-core-3.4.5.2-12.fc16.i686

How reproducible:
always

1) Not all paper sizes available in the print driver are listed in the paper
size dialog
2) paper sizes listed in Format -> Page -> Page - Paper format -> Format are
available under the printing paper sizes.
3) Cannot change the media type under Print -> Properties -> Device -> Media
Type
4) Because of #3, if a single sided media is in media type it cannot be changed
to a two-sided type so duplexing options are not available under Two-Sided.
5) Slow drying paper cannot be set to any other value than the default for the
printer.
6) Not all the trays are listed under paper source.

I am certain there are other issues, but these are the ones that come to the
forefront as I write.

In order to be able to print two-sided in LibreOffice, I have had to select a
two-sided letter as the default media in CUPS. Because of #1 and #3, no
envelope sizes are available.

Often, in order to print something other than letter size, I have to export to
PDF and then print in AdobeReader. Interestingly, the AdobeReader print dialog
has all the printer options and paper sizes available.

Other print dialogs for program such as kate, firefox, thunderbird, kwrite,
gimp,xtuple PostBooks, and every other print dialog I have recently tried
worked just fine.
Comment 1 John Griffiths 2012-04-27 14:56:59 EDT
This was reported upstream.

Note You need to log in before you can comment on or make changes to this bug.