Bug 81717 - Japanese text installer fonts is dirty
Japanese text installer fonts is dirty
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Mike McLean
: FutureFeature
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-13 05:06 EST by Nakai
Modified: 2013-01-10 16:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-18 16:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
k14ucs.bdf - k14 Unicode font converted from k14 in X. (140.25 KB, application/octet-stream)
2003-01-15 02:21 EST, Nakai
no flags Details
7x14ja-RH.bdf.bz2 - result of 'mergebdf 7x14.bdf k14ucs.bdf' (162.98 KB, application/octet-stream)
2003-01-15 02:24 EST, Nakai
no flags Details
7x14ja-RH.bgf - bdftobogl -f 7x14ja-RH.bgf (144.58 KB, application/octet-stream)
2003-01-15 02:35 EST, Nakai
no flags Details
CJK test font - 1 (427.20 KB, application/octet-stream)
2003-02-12 03:26 EST, Leon Ho
no flags Details
14x14cjk.bdf.bz2 (476.03 KB, application/octet-stream)
2003-02-13 23:29 EST, Leon Ho
no flags Details

  None (edit)
Description Nakai 2003-01-13 05:06:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.1) Gecko/20020830

Description of problem:
Japanese text installer fonts is dirty and far from
the market requrements.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run Text Installer with Japanese mode
2. Oops
3.
    

Additional info:

We should use k14 fonts for the installer.
Comment 2 Nakai 2003-01-15 02:21:50 EST
Created attachment 89368 [details]
k14ucs.bdf - k14 Unicode font converted from k14 in X.
Comment 3 Nakai 2003-01-15 02:24:48 EST
Created attachment 89369 [details]
7x14ja-RH.bdf.bz2 - result of 'mergebdf 7x14.bdf k14ucs.bdf'
Comment 4 Nakai 2003-01-15 02:35:24 EST
Created attachment 89370 [details]
7x14ja-RH.bgf - bdftobogl -f 7x14ja-RH.bgf
Comment 5 Nakai 2003-01-15 02:38:57 EST
Just merge the attached fonts and it works here with newt sample test program.
Comment 6 Eido Inoue 2003-01-15 16:00:25 EST
Have you tested with Korean and Chinese?
Comment 7 Nakai 2003-01-16 01:22:18 EST
This font is for Japanese only.

It's a wrong assumption that all CJK fonts are best to show with same 16 bit
size. We should separate J at least for this 14 bit font.

Separating CJK for install disk will take effect to reduce disk size.
Comment 8 Matt Wilson 2003-01-16 01:25:20 EST
are all the 14 dot glyphs centered in a 16 dot cell?
Comment 9 Nakai 2003-01-16 02:47:26 EST
14 dot fonts are in 14 dot cell, so might be in 16 dot cell.
Alphabets are in 7x14, and Japanese fonts are in 14x14.

7x14 alphabets should be used with 14x14 CJK fonts, and
8x16 alphabets should be used with 16x16 CJK fonts.

Comment 11 Eido Inoue 2003-01-16 23:43:31 EST
fonts are perfectly readable-- just an opinion that one font is better than
another (fair enough). Changing severity to enhancement.
Comment 12 Nakai 2003-02-04 10:34:06 EST
The glyph issue is so important that you cannot decide.

Users would laugh at our localize level with a glance before install.
If you still cannot understand the difference between k14 and the poor font,
please never touch any Japanese related issues in the distro.

We cannot ship the product with such dirty font, anyway.
Comment 13 Leon Ho 2003-02-10 20:32:59 EST
Can we merge bdf on 7x14, k14 (JP) with Gulim14 (that needed to be converted 
to UCS) (KR) so that thoughout the screen we will have 14x14? That will be same 
as we have currently - we only have ja and kr bdf font in bterm. 
Comment 14 Eido Inoue 2003-02-11 11:02:57 EST
see bug 82888; we need coverage for zh_TW and zh_HK. (Strangely enough, coverage
for simplified GB2312 seems to be present)-- so we would need a 14x14
big5-charset-based unicode bdf font as well.
Comment 15 Leon Ho 2003-02-12 03:23:24 EST
OK. I have merged the font merged from 7x14 + k14 + gulim14 (converted from 
euc-kr to UCS2) + bsmi00lp (generated from ttf) + gbsn00lp (generated from 
ttf). 
 
By tested it bterm with anaconda, I could not "really" tell the different glyphs from 
different font file in TC and SC. AFAIS, there aren't any missing glyphs anymore 
from TC. We need to test again from installing env though. havill, msw, nakai, 
please have a spin on it. 
Comment 16 Leon Ho 2003-02-12 03:26:25 EST
Created attachment 90023 [details]
CJK test font - 1
Comment 17 Leon Ho 2003-02-12 03:44:16 EST
In our case which we have limited resources on bdf & ttf to use, IMO we only 
have three ways: 
 
- leave as it is. ie. use ucs-fonts-asian 
- use ZYSong18030 to generate a whole set of bdf from ttf2bdf 
- use 14x14 fonts which has two nice bdfs - k14 and gulim14 and then make up 
other glyphs from TTFs 
 
I will choose the 3rd option - korean and japanese text display are pretty nice 
afterward. 
Comment 18 Nakai 2003-02-12 05:01:05 EST
Comment #16 font works and all kanji glyphs are for Japanese.
cat ja.po in anaconda and I've read all.
Comment 19 Eido Inoue 2003-02-13 15:56:58 EST
can you add the bdf sources you used to make that last bgf font to this bug?
(and give me the order you used for mergebdf) thanks.
Comment 20 Leon Ho 2003-02-13 23:29:22 EST
Created attachment 90075 [details]
14x14cjk.bdf.bz2
Comment 21 Leon Ho 2003-02-13 23:34:32 EST
I use this command: 
./mergebdf 7x14.bdf k14ucs.bdf gulim14-ucs.bdf bsmi00lp.bdf gbsn00lp.bdf > 
14x14cjk.bdf 
 
Also we may include the possible license into the package. 
Baekmuk Gulim:  
/usr/share/doc/ttfonts-ko-1.0.11/ttfonts-ko/COPYRIGHT 
AR PL Mingti2L Big5 and AR PL SungtiL GB: 
/usr/share/doc/ttfonts-zh_TW-2.11/doc/arphicpl.txt 
Comment 22 Eido Inoue 2003-02-14 17:14:43 EST
fix in latest bogl

Note You need to log in before you can comment on or make changes to this bug.