Bug 817228 - Posting comments failed
Posting comments failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wei Shen
:
: 795687 (view as bug list)
Depends On:
Blocks: 733411
  Show dependency treegraph
 
Reported: 2012-04-28 02:50 EDT by QinXie
Modified: 2014-06-22 21:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 00:45:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QinXie 2012-04-28 02:50:05 EDT
belowing is the error msg:

Software error:
 DBD::mysql::st execute failed: Duplicate entry '1038358' for key 1 [for Statement "INSERT INTO flags (id, type_id, 
                                       bug_id, attach_id, 
                                       requestee_id, setter_id, status, 
                                       creation_date, modification_date)
                 VALUES (1038358, 
                         16, 
                         755114, 
                         NULL,
                         317380,
                         228291,
                         '?', 
                         '2012-04-27 23:10:40',
                         '2012-04-27 23:10:40')"] at Bugzilla/DB.pm line 65
  Bugzilla::DB::SendSQL('INSERT INTO flags (id, type_id, \x{a}                            ...') called at Bugzilla/Flag.pm line 351
  Bugzilla::Flag::create('HASH(0x1bb29d90)', '\'2012-04-27 23:10:40\'') called at Bugzilla/Flag.pm line 284
  Bugzilla::Flag::process('HASH(0x1bb22b70)', '2012-04-27 23:10:40', 'HASH(0x194f8c00)') called at /var/www/html/hwcert/process.cgi line 2785
Comment 1 Wei Shen 2012-04-28 03:35:35 EDT
The id is an auto increase column, we need not to insert id value.
Comment 2 Wei Shen 2012-04-28 03:36:42 EDT
Created attachment 580942 [details]
remove id from insert sql
Comment 3 Pengfei Xue 2012-04-28 04:20:30 EDT
Comment on attachment 580942 [details]
remove id from insert sql

the patch is good
Comment 4 Rob Landry 2012-04-30 09:58:45 EDT
What is the reproducer for this bug?
Comment 5 Rob Landry 2012-04-30 10:04:48 EDT
Is the flag ID reused later in the code?
Comment 6 Wei Shen 2012-05-01 23:20:06 EDT
(In reply to comment #5)
> Is the flag ID reused later in the code?

No, this flag ID was not reused in the code.
Comment 7 Wei Shen 2012-05-02 22:42:02 EDT
verified on web2
Comment 8 Wei Shen 2012-05-17 03:08:16 EDT
verified on partner
Comment 9 Wei Shen 2012-06-01 01:49:55 EDT
*** Bug 795687 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.