Bug 817316 - AMD fglrx drivers are malfunctioning
AMD fglrx drivers are malfunctioning
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 20:23 EDT by eyurtese
Modified: 2012-05-02 10:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 12:37:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eyurtese 2012-04-28 20:23:35 EDT
Description of problem:
AMD fglrx drivers are malfunctioning

Version-Release number of selected component (if applicable):
Fedora 17
AMD Catalyst 12.4

How reproducible:
Install Fedora 17 then Install Catalyst 12.4

Steps to Reproduce:
1. Install Fedora 17
2. Install Catalyst 12.4
3.
  
Actual results:
It stays at text console...

Expected results:
Login screen 

Additional info:

Device: HP dm1-4100 with AMD E-450 APU processor

# cat /mnt/etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:0:1:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

# cat /mnt/var/log/Xorg.0.log
[   197.643]
X.Org X Server 1.12.0
Release Date: 2012-03-04
[   197.707] X Protocol Version 11, Revision 0
[   197.728] Build Operating System: x86-01 2.6.32-220.4.1.el6.x86_64
[   197.750] Current Operating System: Linux amd-e450.abo.fi 3.3.4-1.fc17.x86_64 #1 SMP Fri Apr 27 18:39:03 UTC 2012 x86_64
[   197.773] Kernel command line: BOOT_IMAGE=/vmlinuz-3.3.4-1.fc17.x86_64 root=UUID=8e6d54e0-5607-4727-9ffd-5175395b213c ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
[   197.820] Build Date: 14 March 2012  03:02:21PM
[   197.844] Build ID: xorg-x11-server 1.12.0-2.fc17
[   197.867] Current version of pixman: 0.24.4
[   197.889]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   197.936] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   198.008] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 29 03:05:34 2012
[   198.031] (==) Using config file: "/etc/X11/xorg.conf"
[   198.055] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   198.078] (==) ServerLayout "aticonfig Layout"
[   198.078] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   198.078] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   198.079] (**) |   |-->Device "aticonfig-Device[0]-0"
[   198.079] (==) Automatically adding devices
[   198.079] (==) Automatically enabling devices
[   198.079] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d,
        built-ins
[   198.079] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   198.079] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   198.079] (II) Loader magic: 0x7c5ac0
[   198.079] (II) Module ABI versions:
[   198.079]    X.Org ANSI C Emulation: 0.4
[   198.079]    X.Org Video Driver: 12.0
[   198.079]    X.Org XInput driver : 16.0
[   198.079]    X.Org Server Extension : 6.0
[   198.080] (--) PCI:*(0:0:1:0) 1002:9806:103c:3387 rev 0, Mem @ 0xe0000000/268435456, 0xf0300000/262144, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[   198.080] (II) "extmod" will be loaded by default.
[   198.080] (II) "dbe" will be loaded by default.
[   198.080] (II) "glx" will be loaded by default.
[   198.080] (II) "record" will be loaded by default.
[   198.080] (II) "dri" will be loaded by default.
[   198.080] (II) "dri2" will be loaded by default.
[   198.080] (II) LoadModule: "extmod"
[   198.081] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[   198.082] (II) Module extmod: vendor="X.Org Foundation"
[   198.082]    compiled for 1.12.0, module version = 1.0.0
[   198.082]    Module class: X.Org Server Extension
[   198.082]    ABI class: X.Org Server Extension, version 6.0
[   198.082] (II) Loading extension SELinux
[   198.082] (II) Loading extension MIT-SCREEN-SAVER
[   198.082] (II) Loading extension XFree86-VidModeExtension
[   198.082] (II) Loading extension XFree86-DGA
[   198.082] (II) Loading extension DPMS
[   198.082] (II) Loading extension XVideo
[   198.082] (II) Loading extension XVideo-MotionCompensation
[   198.082] (II) Loading extension X-Resource
[   198.082] (II) LoadModule: "dbe"
[   198.082] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[   198.082] (II) Module dbe: vendor="X.Org Foundation"
[   198.082]    compiled for 1.12.0, module version = 1.0.0
[   198.082]    Module class: X.Org Server Extension
[   198.082]    ABI class: X.Org Server Extension, version 6.0
[   198.082] (II) Loading extension DOUBLE-BUFFER
[   198.082] (II) LoadModule: "glx"
[   198.082] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   198.083] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   198.083]    compiled for 6.9.0, module version = 1.0.0
[   198.083] (II) Loading extension GLX
[   198.083] (II) LoadModule: "record"
[   198.083] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[   198.084] (II) Module record: vendor="X.Org Foundation"
[   198.084]    compiled for 1.12.0, module version = 1.13.0
[   198.084]    Module class: X.Org Server Extension
[   198.084]    ABI class: X.Org Server Extension, version 6.0
[   198.084] (II) Loading extension RECORD
[   198.084] (II) LoadModule: "dri"
[   198.084] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[   198.084] (II) Module dri: vendor="X.Org Foundation"
[   198.084]    compiled for 1.12.0, module version = 1.0.0
[   198.084]    ABI class: X.Org Server Extension, version 6.0
[   198.084] (II) Loading extension XFree86-DRI
[   198.084] (II) LoadModule: "dri2"
[   198.085] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[   198.085] (II) Module dri2: vendor="X.Org Foundation"
[   198.085]    compiled for 1.12.0, module version = 1.2.0
[   198.085]    ABI class: X.Org Server Extension, version 6.0
[   198.085] (II) Loading extension DRI2
[   198.085] (II) LoadModule: "fglrx"
[   198.085] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[   198.124] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[   198.124]    compiled for 1.4.99.906, module version = 8.96.4
[   198.124]    Module class: X.Org Video Driver
[   198.125] (II) Loading sub module "fglrxdrm"
[   198.125] (II) LoadModule: "fglrxdrm"
[   198.125] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[   198.125] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
[   198.125]    compiled for 1.4.99.906, module version = 8.96.4
[   198.125] (II) ATI Proprietary Linux Driver Version Identifier:8.96.4
[   198.125] (II) ATI Proprietary Linux Driver Release Identifier: 8.961        
[   198.125] (II) ATI Proprietary Linux Driver Build Date: Apr  5 2012 23:06:21
[   198.125] (--) using VT number 1

[   198.184] (WW) Falling back to old probe method for fglrx
[   198.210] (II) Loading PCS database from /etc/ati/amdpcsdb
[   198.213] (--) Chipset Supported AMD Graphics Processor (0x9806) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[   198.213] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:0) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:1) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[   198.214] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[   198.216] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[   198.216] (II) AMD Video driver is signed
[   198.217] (II) fglrx(0): pEnt->device->identifier=0x1299a80
[   198.217] (II) fglrx(0): Loading PCS database from /etc/ati/amdpcsdb
[   198.217]
[   198.217] Backtrace:
[   198.217] 0: X (xorg_backtrace+0x36) [0x464d46]
[   198.217] 1: X (0x400000+0x69d99) [0x469d99]
[   198.218] 2: /lib64/libpthread.so.0 (0x7f21a3e8d000+0xefe0) [0x7f21a3e9bfe0]
[   198.218] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs111_atiddxLeaveVT+0x45) [0x7f21a05e3735]
[   198.218] 4: X (xf86DeleteScreen+0x7c) [0x48b03c]
[   198.218] 5: X (InitOutput+0x9f4) [0x484504]
[   198.218] 6: X (0x400000+0x23246) [0x423246]
[   198.218] 7: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f21a2b14735]
[   198.218] 8: X (0x400000+0x236bd) [0x4236bd]
[   198.218]
[   198.219] Segmentation fault at address 0x10
[   198.219]
Fatal server error:
[   198.219] Caught signal 11 (Segmentation fault). Server aborting
[   198.219]
[   198.219]
Please consult the Fedora Project support
         at http://wiki.x.org
 for help.
[   198.219] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   198.219]
[   198.333] Server terminated with error (1). Closing log file.
Comment 1 Jérôme Glisse 2012-04-30 12:37:43 EDT
Not our issue, closed source driver. Nothing we can do about it
Comment 2 eyurtese 2012-05-02 05:35:49 EDT
well, there are a pile of things that you can do:

1- You can make a bug report to AMD when this sort of problem occurs.
2- You can hold back the kernel which does not properly function.
3- You can improve the upgrade program to detect incompatibilities with newer packages and hardware and warn the user before the upgrade. (perhaps hold back incompatible packages until user confirms upgrade).

Well, these are all I can think of in a moments notice, I am sure there are more which can be done.

Anyway, I guess this is how fedora rolls, every upgrade breaks either NIS, or graphics or something else in our systems. It looks like there is nothing being done to improve the quality of upgrades. Ubuntu seems to be more stable, perhaps it is time to switch.

Thanks for the reply.
Comment 3 Jérôme Glisse 2012-05-02 10:25:19 EDT
We do 1, we won't do 2 or 3 because the fedora experience is designed around out of the box experience ie with the open source driver. We can't and won't try to detect all possible proprietary driver user might add. When you use proprietary driver you loose fedora support (that's my own opinion maybe FESCO and fedora board disagree there).

Note You need to log in before you can comment on or make changes to this bug.