Bug 817390 - bash-completion of subscription-manager subscribe --<TAB><TAB> is not finding --servicelevel option
bash-completion of subscription-manager subscribe --<TAB><TAB> is not finding...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-29 12:22 EDT by John Sefler
Modified: 2012-06-20 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-29 12:22:45 EDT
Description of problem:
This bug requires bash-completion to be installed.

Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.15-1.el6.x86_64
[root@jsefler-r63-server ~]# rpm -q bash-completion
bash-completion-1.3-5.el6.noarch

How reproducible:


Steps to Reproduce:
[root@jsefler-r63-server ~]# subscription-manager subscribe --help
Usage: subscription-manager subscribe [OPTIONS]

Subscribe the registered machine to a specified product

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication
  --pool=POOL           the id of the pool to subscribe to
  --quantity=QUANTITY   number of subscriptions to consume
  --auto                automatically subscribe this system to
                        compatible subscriptions.
  --servicelevel=SERVICE_LEVEL
                        service level to apply to this system
[root@jsefler-r63-server ~]# 
[root@jsefler-r63-server ~]# 
[root@jsefler-r63-server ~]# subscription-manager subscribe --<TAB><TAB>
--auto           --help           --pool           --proxy          --proxypassword  --proxyuser      --quantity       
  

^^ Expected to see --servicelevel included in the tab completion list


Additional info:
Comment 1 John Sefler 2012-04-29 12:26:36 EDT
Same problem with tab completion for the register command options...

[root@jsefler-r63-server ~]# subscription-manager register --help
Usage: subscription-manager register [OPTIONS]

register the client to RHN

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication
  --username=USERNAME   username to use when authorizing against the server
  --password=PASSWORD   password to use when authorizing against the server
  --type=CONSUMERTYPE   the type of consumer to register, defaults to system
  --name=CONSUMERNAME   name of the consumer to register, defaults to the
                        hostname
  --consumerid=CONSUMERID
                        if supplied, the existing consumer data is pulled from
                        the server
  --org=ORG             register to one of multiple organizations for the user
  --environment=ENVIRONMENT
                        register to a specific environment in the destination
                        org
  --release=RELEASE     set a release version
  --autosubscribe       automatically subscribe this system to
                        compatible subscriptions.
  --force               register the system even if it is already registered
  --activationkey=ACTIVATION_KEYS
                        one or more activation keys to use for registration
  --servicelevel=SERVICE_LEVEL
                        service level to apply to this system
[root@jsefler-r63-server ~]# 
[root@jsefler-r63-server ~]# 
[root@jsefler-r63-server ~]# subscription-manager register --<TAB><TAB>
--activationkey  --consumerid     --force          --name           --password       --proxypassword  --type           
--autosubscribe  --environment    --help           --org            --proxy          --proxyuser      --username   


^^ Expected to see --servicelevel and --release included in the tab completion list
Comment 2 Adrian Likins 2012-04-30 09:36:17 EDT
commit 3e8c44be85ddee9b61b4c9daa00ecd4124e23d4b
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Apr 30 09:23:59 2012 -0400

    817390: add completion support for servicelevel
Comment 4 John Sefler 2012-05-03 18:58:47 EDT
Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager bash-completion
subscription-manager-0.99.16-1.el6.x86_64
bash-completion-1.3-5.el6.noarch

[root@jsefler-r63-server ~]# subscription-manager subscribe --
--auto           --pool           --proxypassword  --quantity
--help           --proxy          --proxyuser      --servicelevel

VERIFIED: subscription-manager subscribe --<TAB><TAB> now completes --servicelevel



[root@jsefler-r63-server ~]# subscription-manager register --
--activationkey  --force          --password       --release
--autosubscribe  --help           --proxy          --servicelevel
--consumerid     --name           --proxypassword  --type
--environment    --org            --proxyuser      --username

VERIFIED: subscription-manager register --<TAB><TAB> now completes --release and --servicelevel
Comment 6 errata-xmlrpc 2012-06-20 08:57:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.