Bug 817434 - regression: No mouse cursor reaction when using Quanta Optical Touchscreen on Dell Vostro 360
regression: No mouse cursor reaction when using Quanta Optical Touchscreen on...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 21:39 EDT by pi_raph
Modified: 2012-12-18 19:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 19:56:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lsusb -vvv on updated F17 install (53.64 KB, text/plain)
2012-04-29 21:39 EDT, pi_raph
no flags Details
output of xinput --list on updated F17 install (1.13 KB, text/plain)
2012-04-29 21:41 EDT, pi_raph
no flags Details
output of lsmod on updated F17 install (3.01 KB, text/plain)
2012-04-29 21:43 EDT, pi_raph
no flags Details
output of lsmod on f16 live (where touch works) (3.08 KB, text/plain)
2012-04-29 22:33 EDT, pi_raph
no flags Details
output of evtest on updated f17 - no events (1.62 KB, text/plain)
2012-04-29 22:44 EDT, pi_raph
no flags Details
output of evtest on f16 live - receiving events (2.96 KB, text/plain)
2012-04-29 22:47 EDT, pi_raph
no flags Details

  None (edit)
Description pi_raph 2012-04-29 21:39:41 EDT
Created attachment 581116 [details]
output of lsusb -vvv on updated F17 install

Description of problem:

There is no reaction when trying to use the Touchscreen on a Dell Vostro 360 (reported as Quanta OpticalTouchscreen by xinput,lsusb) under X after booting from a fresh Fedora 17 Beta live stick (with nomodeset). The device is shown by xinput --list and the XFCE mouse setting screen but xinput --test runs without showing any events. The problem persists after installing and updating.
The touchscreen works when booting a fresh Fedora 16 live stick. 
After installing and updating the F16 system it stops working - same symptoms as on F17 Beta.

Version-Release number of selected component (if applicable):
kernel-3.3.0-1.fc17.x86_64
xorg-x11-server-utils-7.5-12.fc17.x86_64
xorg-x11-server-Xorg-1.12.0-2.fc17.x86_64


How reproducible:
The problem is 100% reproducible by booting F17 live cd and trying to use the touchscreen or running xinput --test

 
Actual results:
xinput --test just keeps running without printing any events when touching the screen.

Expected results:
On a fresh Fedora 16 livecd xinput --test prints events when the screen is touched.


Additional info:
Picking kernel as Component is just a guess.
Comment 1 pi_raph 2012-04-29 21:41:51 EDT
Created attachment 581117 [details]
output of xinput --list on updated F17 install
Comment 2 pi_raph 2012-04-29 21:43:18 EDT
Created attachment 581118 [details]
output of lsmod on updated F17 install
Comment 3 pi_raph 2012-04-29 22:33:18 EDT
Created attachment 581119 [details]
output of lsmod on f16 live (where touch works)

no hid-multitouch module loaded on f16 live.
Comment 4 pi_raph 2012-04-29 22:44:56 EDT
Created attachment 581121 [details]
output of evtest on updated f17 - no events
Comment 5 pi_raph 2012-04-29 22:47:02 EDT
Created attachment 581122 [details]
output of evtest on f16 live - receiving events

i'll stop spamming attachments now. will happily provide anything on request.
Comment 6 pi_raph 2012-05-07 08:10:23 EDT
got it working.
not a real solution but when loading my printk enhanced hid-multitouch module I discovered that running rmmod;modprobe twice while in X fixes the problem and I get events and it works as a pointer. This seems to work with the original kernel module as well.
I can now work around all issues of the device (drm_kms_helper.poll=0 required for proper video) which is great for me, for now. Beyond that it should obviously work out of the box for everyone so let me know if there is anything I can do.
Comment 7 Aswin Seshadri 2012-05-16 12:34:30 EDT
@pi_raph

I also have the same Quanta device, could you please let me know in detail how you got it working?
Comment 8 Aswin Seshadri 2012-05-16 12:35:28 EDT
(In reply to comment #6)
> got it working.
> not a real solution but when loading my printk enhanced hid-multitouch module I
> discovered that running rmmod;modprobe twice while in X fixes the problem and I
> get events and it works as a pointer. This seems to work with the original
> kernel module as well.
> I can now work around all issues of the device (drm_kms_helper.poll=0 required
> for proper video) which is great for me, for now. Beyond that it should
> obviously work out of the box for everyone so let me know if there is anything
> I can do.

Sorry for the double post, Could you please let me know details steps? Did you have to do it every time you reboot?
Comment 9 pi_raph 2012-05-21 00:33:10 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > got it working.
> > not a real solution but when loading my printk enhanced hid-multitouch module I
> > discovered that running rmmod;modprobe twice while in X fixes the problem and I
> > get events and it works as a pointer. This seems to work with the original
> > kernel module as well.
> > I can now work around all issues of the device (drm_kms_helper.poll=0 required
> > for proper video) which is great for me, for now. Beyond that it should
> > obviously work out of the box for everyone so let me know if there is anything
> > I can do.
> 
> Sorry for the double post, Could you please let me know details steps? Did
> you have to do it every time you reboot?


Hi,

In X11 open a terminal. su to root. run "rmmod hid-multitouch;modprobe hid-multitouch" twice.
And yes, this needs to be done after every reboot.
Not a great solution but better than nothing. 
Hope it works for you as well.
Comment 10 pi_raph 2012-07-05 18:44:23 EDT
One more problem:
Once in a while rmmod/modprobe leads to a state where all touch events get registered at coordinates 0/0.
Comment 11 pi_raph 2012-12-18 19:56:45 EST
works fine out of the box in f18 beta.
no problems encountered so far.

Note You need to log in before you can comment on or make changes to this bug.