Bug 817502 - Bad rendering of TabPane fonts under KDE
Bad rendering of TabPane fonts under KDE
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
https://bugs.eclipse.org/bugs/show_bu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 05:59 EDT by Mary Ellen Foster
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 07:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the problem (compare the word "Project" in the menu bar with "Project" on the tab label) (30.21 KB, image/png)
2012-04-30 05:59 EDT, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2012-04-30 05:59:54 EDT
Created attachment 581165 [details]
Screenshot showing the problem (compare the word "Project" in the menu bar with "Project" on the tab label)

Description of problem:
I use Eclipse under KDE. The oxygen-gtk package generally takes care of applying my KDE theme to any GTK apps; however, there seems to be an issue with the font on the labels of internal TabPanes. See the attached screenshot: the font in the menu and in the Project Explorer itself is correct, but the font for the words "Project Explorer" is wrong (probably it's using the default GTK font?)

I'm told that the colour of the toolbar is a separate, known issue, so ignore that aspect of the screenshot. :)

Version-Release number of selected component (if applicable):
eclipse-platform-4.2.0-0.17.I201204171000.fc17.x86_64
(NB: I see identical behaviour using Eclipse from the upstream eclipse-SDK-4.2M6-linux-gtk-x86_64.tar.gz tarball)

How reproducible:
Every time

Steps to Reproduce:
1. Run Eclipse on my desktop machine 
  

Additional info:
This computer was just updated from F16 via preupgrade
Comment 1 Mary Ellen Foster 2012-04-30 06:02:57 EDT
For those who can't easily see the difference: the font in the task pane is bigger and rounder than the font in the menu. The menu font is the correct one.
Comment 2 Krzysztof Daniel 2012-04-30 07:41:19 EDT
Since the issue is reproducible with upstream Eclipse, I'm closing this bug as an upstream.

Note You need to log in before you can comment on or make changes to this bug.