Bug 817539 - authconfig doesn't return non-zero on invalid args
authconfig doesn't return non-zero on invalid args
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 08:37 EDT by Stef Walter
Modified: 2012-08-15 12:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 12:11:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-04-30 08:37:31 EDT
Description of problem:

When passed invalid arguments authconfig does not return a non-zero exit code. Returning a zero exit code when not actually successful makes it difficult to use from scripts that need to manage PAM modules.

Version-Release number of selected component (if applicable):

Name        : authconfig
Arch        : x86_64
Version     : 6.2.1
Release     : 1.fc17
Size        : 1.9 M

How reproducible:

Every time

Steps to Reproduce:

# authconfig --enablewinbind
# echo $?

Actual results:

Above command hash zero exit code.

Expected results:

Should have a non-zero exit code.
Comment 1 Tomas Mraz 2012-04-30 09:22:56 EDT
This currently happens only in case the action option is missing. However it is clearly a bug and I fixed it in the upstream repository.
Comment 2 Stef Walter 2012-04-30 11:30:11 EDT
Thanks.
Comment 3 Stef Walter 2012-08-15 12:11:31 EDT
This looks liked in authconfig-6.2.3

Note You need to log in before you can comment on or make changes to this bug.