Bug 817544 - 3.1 - VDSM - Storage: disconnectStoragePool fails
3.1 - VDSM - Storage: disconnectStoragePool fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.1
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Federico Simoncelli
Gadi Ickowicz
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 09:02 EDT by Daniel Paikov
Modified: 2014-08-21 21:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: vdsm-4.9.6-22.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 02:49:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (1.18 MB, application/x-compressed-tar)
2012-04-30 09:02 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-04-30 09:02:43 EDT
Created attachment 581181 [details]
vdsm.log

* Local storage pool with 2 data domains.
* Initiate failure in master domain.
* Reconstruct fails because disconnectStoragePool fails.
Comment 1 Yaniv Kaul 2012-04-30 09:11:51 EDT
Regression?
Comment 3 Dan Kenigsberg 2012-05-09 05:49:30 EDT
Why is it marked a regression? Since which vdsm version?
Comment 4 Daniel Paikov 2012-05-10 03:37:44 EDT
(In reply to comment #3)
> Why is it marked a regression? Since which vdsm version?

AFAIK this used to work in 3.0.
Comment 7 Eduardo Warszawski 2012-07-08 04:23:43 EDT
Changed title:
3.1 - VDSM - Storage: Reconstruct on local storage fails -> disconnectStoragePool fails.


disconnectStoragePool will fail disregarding the storage domain type.

Should be fixed by:
http://gerrit.ovirt.org/#/c/3929/20

But the real issue is that hostID has nothing to do with pool / SDM semantics.
Comment 9 Federico Simoncelli 2012-08-02 09:45:30 EDT
Fixed in 4.9.6-22.0:

* Mon Jul 16 2012 Igor Lvovsky <ilvovsky@redhat.com> - 4.9.6-22.0
- BZ#839330 Monitor the host id in domainMonitor
Comment 10 Gadi Ickowicz 2012-08-06 02:44:02 EDT
verified on SI13. Master domain is reconstructed on 2nd domain.

vdsm-4.9.6-26.0.el6_3.x86_64

Note You need to log in before you can comment on or make changes to this bug.