Bug 817548 - RFE: UI legend/documentation for Translation Memory diff colour coding
RFE: UI legend/documentation for Translation Memory diff colour coding
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
1.6-SNAPSHOT
All Linux
unspecified Severity medium
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 09:23 EDT by Manoj Kumar Giri
Modified: 2015-04-19 20:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20120921-1422)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:24:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manoj Kumar Giri 2012-04-30 09:23:23 EDT
Description of problem:
Not able to understand the highlighted colours & strikethrough portions without proper documentation.

Version-Release number of selected component (if applicable):

Zanata-1.6.0 alpha

How reproducible:
Always


Steps to Reproduce:
1.Run any application.
2.Check for the translation suggestions for any particular string.
3.Try to differentiate the colours and strikethrough portions to use the memory in translating that string.
  
Actual results:
The logic is bit difficult to understand as we don't have any documentation regarding that.

Expected results:
We should have proper documentation to differentiate the colours & strikethrough portions provided in the suggestions. And it will be better if that can be simpler.

Additional info: After closely examining it seems to be bit different in terms of logic from existing off-line tool.
Comment 1 Runa Bhattacharjee 2012-04-30 09:27:25 EDT
We probably need a legend for this in some corner of the UI.
Comment 2 Shankar Prasad 2012-05-02 06:17:49 EDT
my two cents!

I too feel that there is bit difficulty in understanding this coloured, and uncoloured contents. 

Also, as a feature, colouring of matched and unmatched content in the suggested entry should also customizable.

hth
Shanky
Comment 3 Runa Bhattacharjee 2012-07-30 09:17:21 EDT
Request for technical evaluation.
Comment 4 David Mason 2012-07-30 20:44:54 EDT
Note that the same diff style is used for replacement previews in search page, so the same legend should be available for this page, and any colour customization could be used in both locations.

I propose that colour customization be a persistent option per user, since it would take too much input to change it for each new editor tab.
Comment 5 Alex Eng 2012-09-18 20:14:44 EDT
Implement info panel for color explanation in TM panel and search and replace.

See https://github.com/zanata/zanata/commit/6a5e5fc7919bee72fffc81dbd036857562c837d8
Comment 6 Ding-Yi Chen 2012-09-23 23:53:14 EDT
VERIFIED with 1.8.0-SNAPSHOT (20120921-1422)
Comment 7 Sean Flanigan 2013-11-26 22:14:55 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:16:32 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 9 Sean Flanigan 2013-11-26 22:18:23 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 10 Sean Flanigan 2013-11-26 22:24:30 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 11 Sean Flanigan 2013-11-26 22:33:05 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 12 Sean Flanigan 2013-11-26 22:35:19 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.