Bug 817566 - move qemu-kvm to /usr/libexec
move qemu-kvm to /usr/libexec
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks: 819083 819086
  Show dependency treegraph
 
Reported: 2012-04-30 10:13 EDT by Eduardo Habkost
Modified: 2014-06-17 23:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-1.2.0-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 819083 819086 (view as bug list)
Environment:
Last Closed: 2014-06-13 06:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2012-04-30 10:13:55 EDT
qemu-kvm is not supposed to be run directly by users, but used through libvirt. To make this clear, the qemu-kvm binary should be moved to /usr/libexec.
Comment 4 Daniel Berrange 2012-05-14 14:13:07 EDT
More broadly just moving qemu-kvm to /usr/libexec is not sufficient to replicate the RHEL-6 RPM layout. There are other things like the sub-package renaming changes to consider.
Comment 5 Richard W.M. Jones 2012-05-14 14:30:20 EDT
(In reply to comment #4)
> More broadly just moving qemu-kvm to /usr/libexec is not sufficient to
> replicate the RHEL-6 RPM layout. There are other things like the sub-package
> renaming changes to consider.

Shouldn't we stay close to Fedora, not RHEL 6?
Comment 6 Richard W.M. Jones 2012-05-14 14:31:18 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > More broadly just moving qemu-kvm to /usr/libexec is not sufficient to
> > replicate the RHEL-6 RPM layout. There are other things like the sub-package
> > renaming changes to consider.
> 
> Shouldn't we stay close to Fedora, not RHEL 6?

In case it's not clear, I'm talking about names of subpackages;
NOT /usr/libexec which is necessary for the reasons outlined
in comment 0.
Comment 7 Eduardo Habkost 2012-05-14 15:29:37 EDT
(In reply to comment #5)
> Shouldn't we stay close to Fedora, not RHEL 6?

Yes, why should we try to replicate the RHEL6 RPM layout? I would rather keep the layout closer to Fedora than to RHEL6. As long as upgrades work and dependencies between RHEL components are correct, I never considered the RPM package layout an external interface that would be kept stable across major RHEL versions.

The package rename (and possible package layout changes) is being proposed/discussed at bug 817565. But the purpose of bug 817565 was not to replicate the RHEL-6 package layout.
Comment 11 juzhang 2013-10-28 00:15:01 EDT
Verified with qemu-kvm-1.5.3-10.el7.
#ls /usr/libexec/ | grep -i qemu
qemu-ga
qemu-kvm
Comment 12 Ludek Smid 2014-06-13 06:47:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.