Bug 817568 - internal server error when listing systems from a particular group
internal server error when listing systems from a particular group
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity high (vote)
: 0.9.0
: ---
Assigned To: Raymond Mancy
:
: 818525 828183 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:14 EDT by Ales Zelinka
Modified: 2014-12-07 20:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:40:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Dan Callaghan 2012-04-30 19:07:46 EDT
Here is a stack trace.

2012-04-30 19:06:59,302 cherrypy.msg INFO HTTP: Page handler: <bound method Groups.systems of <bkr.server.group.Groups object at 0x7ff08a5f1710>>
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 121, in _run
    self.main()
  File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 264, in main
    body = page_handler(*virtual_path, **self.params)
  File "<string>", line 3, in systems
  File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 361, in expose
    *args, **kw)
  File "<generated code>", line 0, in run_with_transaction
  File "/usr/lib/python2.6/site-packages/peak/rules/core.py", line 153, in __call__
    return self.body(*args, **kw)
  File "/usr/lib/python2.6/site-packages/turbogears/database.py", line 458, in sa_rwt
    retval = func(*args, **kw)
  File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 244, in _expose
    @abstract()
  File "<generated code>", line 0, in _expose
  File "/usr/lib/python2.6/site-packages/peak/rules/core.py", line 153, in __call__
    return self.body(*args, **kw)
  File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 390, in <lambda>
    fragment, options, args, kw)))
  File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 425, in _execute_func
    output = errorhandling.try_call(func, *args, **kw)
  File "/usr/lib/python2.6/site-packages/turbogears/errorhandling.py", line 77, in try_call
    return func(self, *args, **kw)
  File "/usr/lib/python2.6/site-packages/bkr/server/group.py", line 157, in systems
    systems = System.by_group(group_id)
  File "/usr/lib/python2.6/site-packages/bkr/server/model.py", line 1947, in by_group
    return System.query.join(['groups']).filter(Group.group_id == group_id)
  File "<string>", line 1, in <lambda>
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/util.py", line 292, in go
    return fn(*(list(args[0:-1]) + args[-1]), **kw)
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/orm/query.py", line 1224, in join
    from_joinpoint=from_joinpoint)
  File "<string>", line 1, in <lambda>
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/orm/query.py", line 52, in generate
    fn(self, *args[1:], **kw)
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/orm/query.py", line 1326, in _join
    raise NotImplementedError("query.join(a==b) not supported.")
NotImplementedError: query.join(a==b) not supported.
Comment 2 Raymond Mancy 2012-05-03 21:02:37 EDT
*** Bug 818525 has been marked as a duplicate of this bug. ***
Comment 3 Raymond Mancy 2012-05-04 03:25:04 EDT
On gerrit 
http://gerrit.beaker-project.org/#/c/1045
Comment 6 Dan Callaghan 2012-06-04 18:08:48 EDT
*** Bug 828183 has been marked as a duplicate of this bug. ***
Comment 7 Dan Callaghan 2012-06-26 02:40:32 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.