Bug 817648 - cli: peer probe returns value 0 even in case of error
cli: peer probe returns value 0 even in case of error
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 14:09 EDT by Sachidananda Urs
Modified: 2014-04-17 07:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:38:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-04-30 14:09:03 EDT
[root@gqac026 ~]# gluster peer probe 10.16.157.781
Usage: peer probe <HOSTNAME>
[root@gqac026 ~]# echo $?
0

In the above case, the peer probe has failed due to wrong ip address. In such cases return a value other than 0. This helps while scripting these commands.
Comment 1 Kaushal 2012-06-06 00:10:14 EDT
Fixed by commit ada4ab0 (cli: Fix error output for peer probe on address validation failure)
Comment 2 Sachidananda Urs 2012-12-19 02:53:52 EST
[root@dhcp159-156 tmp]#  gluster peer probe 10.16.157.781
[root@dhcp159-156 tmp]# echo $?
1
[root@dhcp159-156 tmp]# 

This is a regression. No ipv4 validation done. I expect to see a message saying ip address is wrong and fail with a non-zero error code.
Comment 3 Amar Tumballi 2013-02-17 23:56:13 EST
(In reply to comment #2)
> This is a regression. No ipv4 validation done. I expect to see a message
> saying ip address is wrong and fail with a non-zero error code.

Should we rather open different bug for missing validation? or you are saying earlier there was validation, and now we removed it?

This is the error on latest master.

[root@supernova ~]# gluster peer probe 10.16.157.781
peer probe: failed: Probe returned with unknown errno 107
[root@supernova ~]# echo $?
1
Comment 4 Niels de Vos 2014-04-17 07:38:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.