Bug 817652 - Patches give warning of unexpected ending while compiling 3.3.4 kernel
Patches give warning of unexpected ending while compiling 3.3.4 kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 14:29 EDT by stan
Modified: 2012-04-30 15:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 15:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stan 2012-04-30 14:29:41 EDT
Description of problem:
While building the kernel with rpmbuild, several patches warn that they ended unexpectedly.  
patch unexpectedly ends in middle of line

Version-Release number of selected component (if applicable):
3.3.4

How reproducible:
Every time I compile.

Steps to Reproduce:
1.  Configure kernel
2.  Run rpmbuild -bb
3.
  
Actual results:
Warning is generated:
patch unexpectedly ends in middle of line


Expected results:
No warning

Additional info:
The three patches that generate this warning are:
Patch14001: hibernate-watermark.patch
Patch21250: mcelog-rcu-splat.patch
Patch22012: ipw2200-Fix-race-condition-in-the-command-completion-acknowledge.patch

This is just to let you know that this is happening.  Can't be good, but the kernels seem to run.
Comment 1 Josh Boyer 2012-04-30 15:14:31 EDT
(In reply to comment #0)
> Additional info:
> The three patches that generate this warning are:
> Patch14001: hibernate-watermark.patch
> Patch21250: mcelog-rcu-splat.patch
> Patch22012:
> ipw2200-Fix-race-condition-in-the-command-completion-acknowledge.patch
> 
> This is just to let you know that this is happening.  Can't be good, but the
> kernels seem to run.

It's not really an issue.  All three patches are just confusing patch because they were either taken from a mailing list (the first and last) and have extra stuff at the bottom of the patch, or in the case of mcelog, there is just extra whitespace.  The generated code is fine.

Thanks for the report.  We'll try and avoid this where possible in the future.

Note You need to log in before you can comment on or make changes to this bug.