Bug 817710 - RFE: csprocessor revisions report pre and post
RFE: csprocessor revisions report pre and post
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 20:31 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.26.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:29:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-04-30 20:31:33 EDT
At the moment csprocessor revisions returns a list of pre and post-processed content specs, but doesn't clearly state which is which.

Maybe something like this?

(I've used "pre-" and "post" to keep the columns lined up, which is good for readability)

INFO: Revisions for Content Specification ID: 8441
-> ID: 68771 [post] Tue, May 1, 2012 at 02:03:25 PM
-> ID: 68768 [pre-] Tue, May 1, 2012 at 02:03:24 PM
-> ID: 68632 [post] Mon, Apr 30, 2012 at 08:09:28 PM
-> ID: 68630 [pre-] Mon, Apr 30, 2012 at 08:09:26 PM
-> ID: 68616 [post] Mon, Apr 30, 2012 at 07:41:12 PM
-> ID: 68615 [pre-] Mon, Apr 30, 2012 at 07:41:12 PM
-> ID: 68580 [post] Mon, Apr 30, 2012 at 06:53:55 PM
-> ID: 68578 [pre-] Mon, Apr 30, 2012 at 06:53:54 PM
-> ID: 68562 [post] Mon, Apr 30, 2012 at 06:46:41 PM
-> ID: 68560 [pre-] Mon, Apr 30, 2012 at 06:46:40 PM
-> ID: 68515 [post] Mon, Apr 30, 2012 at 06:05:57 PM
-> ID: 68514 [pre-] Mon, Apr 30, 2012 at 06:05:56 PM


What would be good is if the post and pre were reversed, so that the post-processed spec revision comes after its pre-processed version.
Comment 1 Lee Newson 2012-04-30 20:59:21 EDT
I can add the pre and post tags but the last request isn't possible as its managed on a global scale by envers. So the revisions will always be different and the value between each will always change depending on the amount of changed content in a spec (ie new/edited topics).

As for the [pre-] its not needed as everything is formatted anyways.
Comment 2 Joshua Wulf 2012-04-30 21:58:10 EDT
Yeah, ignore the request to put pre before post - I just noticed that the most recent revision is at the top of the list... so each pre /is/ before its post.

I wonder if my consistently reading the list the wrong way is the result of an expectation created by other revision lists that have "most recent at bottom".

I guess since I read a page from top to bottom, I'm expecting time to flow in that direction. I start reading at the top, the history starts at the top, in the distant past. I read down to the end (the bottom) I arrive at the present....
Comment 3 Lee Newson 2012-07-30 20:59:55 EDT
Added in 0.26.3

The Revisions command will now display the revision list in ascending order based on the Revisions. It will also display the Pre and Post processed meta data to give the user the ability to see the type of revision.

Example Output:

Content Spec Revisions:

INFO: Revisions for Content Specification ID: 7210
-> ID:  56336 [ Pre Processed] on Thu, Mar 29, 2012 at 02:14:57 AM
-> ID:  56397 [Post Processed] on Thu, Mar 29, 2012 at 02:15:16 AM
...
-> ID:  71331 [ Pre Processed] on Fri, May 04, 2012 at 04:17:34 AM
-> ID:  71333 [Post Processed] on Fri, May 04, 2012 at 04:18:16 AM
-> ID: 153308 [Post Processed] on Mon, Jul 23, 2012 at 02:17:26 PM
-> ID: 153309 [Post Processed] on Mon, Jul 23, 2012 at 02:18:27 PM
-> ID: 153311 [ Pre Processed] on Tue, Jul 24, 2012 at 08:19:43 AM
-> ID: 153313 [Post Processed] on Tue, Jul 24, 2012 at 08:19:45 AM
-> ID: 153314 [ Pre Processed] on Tue, Jul 24, 2012 at 08:24:21 AM
-> ID: 153315 [ Pre Processed] on Tue, Jul 24, 2012 at 08:26:18 AM
-> ID: 153316 [ Pre Processed] on Tue, Jul 24, 2012 at 08:29:13 AM
-> ID: 153319 [Post Processed] on Tue, Jul 24, 2012 at 08:30:10 AM
-> ID: 153320 [ Pre Processed] on Tue, Jul 24, 2012 at 03:43:31 PM
-> ID: 153323 [Post Processed] on Tue, Jul 24, 2012 at 03:43:57 PM
-> ID: 153325 [ Pre Processed] on Fri, Jul 27, 2012 at 02:55:12 PM
-> ID: 153326 [Post Processed] on Fri, Jul 27, 2012 at 02:55:13 PM
-> ID: 153327 [ Pre Processed] on Fri, Jul 27, 2012 at 03:27:20 PM
-> ID: 153328 [Post Processed] on Fri, Jul 27, 2012 at 03:27:21 PM
-> ID: 153329 [ Pre Processed] on Fri, Jul 27, 2012 at 03:33:17 PM
-> ID: 153330 [Post Processed] on Fri, Jul 27, 2012 at 03:33:18 PM
-> ID: 153331 [ Pre Processed] on Fri, Jul 27, 2012 at 03:34:30 PM
-> ID: 153332 [Post Processed] on Fri, Jul 27, 2012 at 03:34:30 PM
-> ID: 153333 [ Pre Processed] on Fri, Jul 27, 2012 at 03:38:39 PM
-> ID: 153334 [Post Processed] on Fri, Jul 27, 2012 at 03:38:39 PM
-> ID: 153335 [ Pre Processed] on Fri, Jul 27, 2012 at 03:39:47 PM
-> ID: 153336 [Post Processed] on Fri, Jul 27, 2012 at 03:41:16 PM
-> ID: 153337 [ Pre Processed] on Fri, Jul 27, 2012 at 04:49:45 PM
-> ID: 153338 [Post Processed] on Fri, Jul 27, 2012 at 04:49:46 PM
-> ID: 153339 [ Pre Processed] on Fri, Jul 27, 2012 at 04:50:17 PM
-> ID: 153340 [ Pre Processed] on Fri, Jul 27, 2012 at 04:51:26 PM
-> ID: 153341 [ Pre Processed] on Fri, Jul 27, 2012 at 04:55:14 PM
-> ID: 153342 [ Pre Processed] on Fri, Jul 27, 2012 at 04:55:14 PM
-> ID: 153343 [ Pre Processed] on Fri, Jul 27, 2012 at 04:57:05 PM

Topic Revisions:

INFO: Revisions for Topic ID: 3737
-> ID:      1 on Thu, Jan 01, 1970 at 10:00:02 AM
-> ID:   1930 on Fri, Jul 01, 2011 at 09:46:54 AM
-> ID:  11824 on Thu, Nov 03, 2011 at 11:06:02 AM
-> ID:  79132 on Mon, May 21, 2012 at 02:09:54 PM
-> ID:  79133 on Mon, May 21, 2012 at 02:10:06 PM
-> ID:  79134 on Mon, May 21, 2012 at 02:10:22 PM
-> ID:  86106 on Mon, May 21, 2012 at 09:53:01 PM
-> ID: 153305 on Mon, Jul 23, 2012 at 09:58:06 AM
-> ID: 153306 on Mon, Jul 23, 2012 at 10:02:33 AM
-> ID: 153307 on Mon, Jul 23, 2012 at 10:04:44 AM
Comment 4 Lee Newson 2013-06-06 21:29:06 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.