Bug 817741 - Spelling: lowercase java, and word boundaries
Spelling: lowercase java, and word boundaries
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 01:30 EDT by Misty Stanley-Jones
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 21:10:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2012-05-01 01:30:00 EDT
Lowercase "java" is probably incorrect with whitespace around it, but surrounded by _ or - or inside a <filename>, <code>, <literal>, <command>, or other similar tag, it is probably OK. I can't find any instances in topic 304.
Comment 1 Matthew Casperson 2012-05-03 20:24:34 EDT
In what situation would the word java by _ or - ever not be a <filename>, <code>, <literal>, <command>?
Comment 2 Matthew Casperson 2012-05-03 21:05:11 EDT
In the case of topic 304 the XML

<title>Optional: Set java_sdk_1.6.0.</title>

is returning the word java_sdk_1.6.0, which is being split up into the word java, sdk, 1, 6, and 0. "java_sdk_1.6.0" should be enclosed in a literal or something similar.
Comment 3 Matthew Casperson 2012-05-03 21:10:42 EDT
The spell checker has been modified to not split words based on an underscore or dash. This still doesn't resolve the issue with terms like "java_sdk_1.6.0" since it contains periods. Such terms will still have to be enclosed in the appropriate docbook tags.
Comment 4 Misty Stanley-Jones 2012-05-03 21:14:42 EDT
Well spotted. Thanks!

Note You need to log in before you can comment on or make changes to this bug.