Bug 817835 - Panic: Stack corruption in printk_all_partitions on Dell XPS 17 (as of kernel 3.3.4-1.fc17)
Panic: Stack corruption in printk_all_partitions on Dell XPS 17 (as of kernel...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 10:21 EDT by Erik van Pienbroek
Modified: 2014-01-08 17:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-05 11:37:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo capture of the kernel panic (540.41 KB, image/jpeg)
2012-05-01 10:21 EDT, Erik van Pienbroek
no flags Details

  None (edit)
Description Erik van Pienbroek 2012-05-01 10:21:43 EDT
Created attachment 581384 [details]
Photo capture of the kernel panic

As of kernel 3.3.4-1.fc17 a fatal kernel panic is thrown just after the kernel gets started by grub. There appears to be some stack corruption occurring in the printk_all_partitions function. See attached image.

Hardware is a Dell XPS 17 notebook.
Last working kernel is kernel 3.3.2-8.fc17
Comment 1 Erik van Pienbroek 2012-05-05 11:37:34 EDT
This issue seems to be resolved with kernel 3.3.4-3.fc17.x86_64
Comment 2 Charlie Brady 2014-01-08 17:29:26 EST
> This issue seems to be resolved with kernel 3.3.4-3.fc17.x86_64

I'm seeing it with 3.3.4-5.fc17.

The bug seems to be this:

http://comments.gmane.org/gmane.linux.kernel/1294435

It does seem to have been fixed by 3.9.10-100.fc17.

Note You need to log in before you can comment on or make changes to this bug.