Bug 817877 - Mismatched rtnl_lock/rtnl_unlock in netpoll_setup
Mismatched rtnl_lock/rtnl_unlock in netpoll_setup
Status: CLOSED DUPLICATE of bug 816034
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
urgent Severity medium
: rc
: ---
Assigned To: Herbert Xu
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 12:41 EDT by Stuart Hodgson
Modified: 2012-05-30 10:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 21:06:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Hodgson 2012-05-01 12:41:42 EDT
Description of problem:
While testing 6.3Beta update unloading of the sfc driver causes asserts on mutex_unlock.

Version-Release number of selected component (if applicable):
6.3Beta update, kernel 2.6.32-262.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot system with sfc nic
2. Initialise netconsole
2. unload sfc driver
3. see asserts
  
Actual results:
Assert raised for each call to mutex_unlock via rtnl_unlock

Expected results:
No assertaions

Additional info:
After building the kernel sources with CONFIG_DEBUG_MUTEXS it could be seen that the first assertion in the mutex-debug code was seen in netpoll_setup during the initialisation of the netconsole.

Further looking at this shows a missmatch between rntl_lock/rtnl_unlock in the netpoll_setup/__netpoll_setup functions.


netpoll_setup(...) at net/core/netpoll.c:857
   ...
   rtnl_lock();
   __netpoll_setup();
   rtnl_unlock();
   ...

__netpoll_setup(...) at net/core/netpoll.c:754
   rtnl_unlock();

There is no match for this second unlock.

Possible Cause
The introduction of this seems to come from a backport of 
8fdd95ec162a8fbac7f41d6f54f90402fe3e8cb1 from kernel.org

There another patch
deb0d7c740a008a4e26806317497549b0e8907eb that removed this extra rtnl_unlock that may not have been backported.
Comment 2 RHEL Product and Program Management 2012-05-05 00:17:28 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Herbert Xu 2012-05-29 21:06:25 EDT
This is the same as 816034.

*** This bug has been marked as a duplicate of bug 816034 ***

Note You need to log in before you can comment on or make changes to this bug.