Bug 817920 - system-config-printer fails to configure Lexmark X1270
system-config-printer fails to configure Lexmark X1270
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 15:27 EDT by David W. Legg
Modified: 2012-05-02 11:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 09:41:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David W. Legg 2012-05-01 15:27:48 EDT
Description of problem:
Tries to configure a Lexmark X1270 as a Lexmark Optra Color 1200, but test page does not print.  This is on the current fc17 beta i686.

Version-Release number of selected component (if applicable):
system-config-printer-1.3.9-1.fc17.i686

How reproducible:
100% on Fedora 17 beta as of 2012/05/01

Steps to Reproduce:
1. start system-config-printer as root
2. Do New printer.
3. Choose Lexmark 1200
4. Choose Lexmark Optra Color 1200 Foomatic driver (as recommended by the GUI)
5. Forward/Apply etc. Change page size to A4 (in my case). Apply again.
6. Click on Print Test Page
7. Nothing.
  
Actual results:
Nothing printed.
Test page joins printer queue for 10 or 20 seconds then disappears.
No errors in cups /var/log/cupserror_log.
No errors in /var/log/messages

Expected results:
Test page printed.

Additional info:
All works if I install the old z600 drivers CJLZ600LE-CUPS-1.0-1.TAR.gz from Lexmark.  But those were aimed at Fedora 9 of course!
Comment 1 David W. Legg 2012-05-01 15:28:44 EDT
BTW It's great that you guys are now endeavouring to support Lexmark printers. Thanks.
Comment 2 Tim Waugh 2012-05-02 06:24:42 EDT
(In reply to comment #0)
> 1. start system-config-printer as root

(You don't need to run it as root; in fact it's better if you do not.)

> 5. Forward/Apply etc. Change page size to A4 (in my case). Apply again.

(This looks like your "Region and Language" settings are not quite right, in particular the "System" part looks like it needs some attention.)

==

The foomatic database has no information about this particular model.  The closest models are:

Lexmark Optra Color 1200
Lexmark Optra Color 1275
...and both of these use PostScript.

What does 'lpinfo -l -v' say when the printer is connected and powered on?
Comment 3 David W. Legg 2012-05-02 08:27:17 EDT
Hello Tim.  Comments and info.

1. Yes I do have to run system-config-printer as root.
Running as a normal user means that it asks for the root password.
There is obviously a bug in the helper gui, because authentication always fails.
Running as root is just a work-around for the time being.

2. Region and lang is:
LANG=en_US.UTF-8
This would be en_GB (or is it UK?) for us here, hence use of A4 printers.

3. lpinfo -l -v says lots of stuff, including:-
...
Device: uri = usb://Lexmark/1200%20Series
        class = direct
        info = Lexmark 1200 Series
        make-and-model = Lexmark 1200 Series
        device-id = MFG:Lexmark ;CMD:CPDNPA001;MODEL:1200 Series;CLASS:Printer;DES:Lexmark 1200 Series;COMMENT:021127-1;
        location = 

I guess Lexmark are re-using their model numbers, or not really grouping them very helpfully, and the Fedora gui got misled?
Comment 4 Tim Waugh 2012-05-02 09:41:16 EDT
(In reply to comment #3)
> Hello Tim.  Comments and info.
> 
> 1. Yes I do have to run system-config-printer as root.
> Running as a normal user means that it asks for the root password.
> There is obviously a bug in the helper gui, because authentication always
> fails.

Sure it's asking for root's password, not your own password?  If you've set your user account as administrator account type then it will ask for *your* password. (This is working for me.)

> 2. Region and lang is:
> LANG=en_US.UTF-8
> This would be en_GB (or is it UK?) for us here, hence use of A4 printers.

Right: as I said, you need to correct that in "Region and Language", specifically in the System tab, in order to get the correct page size automatically.

> 3. lpinfo -l -v says lots of stuff, including:-
> ...
> Device: uri = usb://Lexmark/1200%20Series
>         class = direct
>         info = Lexmark 1200 Series
>         make-and-model = Lexmark 1200 Series
>         device-id = MFG:Lexmark ;CMD:CPDNPA001;MODEL:1200
> Series;CLASS:Printer;DES:Lexmark 1200 Series;COMMENT:021127-1;
>         location = 
> 
> I guess Lexmark are re-using their model numbers, or not really grouping them
> very helpfully, and the Fedora gui got misled?

Thanks.  So unfortunately this particular model does not claim to understand PostScript at all, only "CPDNPA001" -- whatever language that is.  I think you may be out of luck with getting this to work with free software.
Comment 5 David W. Legg 2012-05-02 10:12:36 EDT
Indeed, users with similar problem will have to get CJLZ600LE-CUPS-1.0-1.TAR.gz and follow these instructions:

http://heuristically.wordpress.com/2010/12/03/install-lexmark-x1150-printer-driver-fedora/

Shame.

It would be nice if, the system-config-printer thingy just said "sorry, unsupported printer".

Thanks for looking at this.
Comment 6 Tim Waugh 2012-05-02 11:39:40 EDT
The infrastructure is not yet in place for it to be able to know for sure that the "best match" driver would *not* support that printer.

Note You need to log in before you can comment on or make changes to this bug.