Bug 817958 - jenkins benchmark scale-up events hit application limit in an unusual place
jenkins benchmark scale-up events hit application limit in an unusual place
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 17:05 EDT by Rob Millner
Modified: 2015-05-14 18:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 16:50:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-05-01 17:05:45 EDT
Description of problem:
When the benchmark job's profiles are analysed, they show that the second and third scale-up events for a scalable jboss app don't run the connector-hooks.  This behaviour doesn't repeat on the same image when doing it by hand.

Version-Release number of selected component (if applicable):


How reproducible:
Frequently in the Jenkins benchmark job.
Never outside of the jenkins benchmark job.

Steps to Reproduce:
1. Run the benchmark job.
2. Collect the artefacts and analyse with rhc-profiler-merge-report
3. Examine the output for scaled jboss applications.
  
Actual results:
The second and third scale-up events don't have connector-execute calls.

Expected results:
All scale-up events have connector-execute calls.

Additional info:
Comment 1 Rob Millner 2012-05-08 13:23:22 EDT
Changing severity to low since this only appears to affect benchmark testing and not real application work-flow.
Comment 2 Rob Millner 2012-05-23 17:16:58 EDT
The call gets a 500 error, and we see the following close to the end.  Strangely enough though this message is after we talk create the gear and talk to dynect.  There's code in the benchmark to increase gears for the test user.  This doesn't happen if the app is created and scaled by hand or by a script that runs on its own.

    Application limit has reached for 'cucumber-test+ci82819178@example.com'
Comment 3 Rob Millner 2012-06-14 19:44:41 EDT
Git commit 0ac0135b6 fixes a bad command line argument to increase the max gears per user.
Comment 4 Rob Millner 2012-06-19 16:50:46 EDT
Clearing this bug off as wontfix.  Yes its an awkward spot to do it but we no longer return a server error; instead we return a 422 error.

Note You need to log in before you can comment on or make changes to this bug.