Bug 817965 - slrn disconnects after authentication on some servers
slrn disconnects after authentication on some servers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: slrn (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Petr Pisar
BaseOS QE - Apps
: Patch
Depends On:
Blocks: 921048
  Show dependency treegraph
 
Reported: 2012-05-01 18:10 EDT by Pasi Sjöholm
Modified: 2013-10-31 05:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 05:30:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pasi Sjöholm 2012-05-01 18:10:52 EDT
Please patch the current version of slrn with this patch on the slrn git.

Revision 324
Modified Mon Sep 6 22:41:04 2010 UTC
src/nntplib.c: slrn user "narke" discovered that his server will
disconnect if an attempt is made to post an empty body. slrn does
this after authenticating with the server to verify that posting
is possible. As a work-around, the response comment from the
AUTHINFO command is parsed.


nntplib.c:

--cut--
  switch (nntp_server_vcmd (s, "AUTHINFO PASS %s", pass))
     {
      case -1:
        return -1;
      case OK_AUTH:
        if (s->can_post == 1)
          break;
        /* This is the only obvious way to find out whether we are
         * able to post after successful authentication.
         *
         * However, at least one server will disconnect if an attempt
         * is made to post an empty article.  Try to avoid this by
         * looking at the response message.  Unfortunately, this method
         * is not very robust.
         */
        if (NULL != strstr (s->rspbuf, "Posting Allowed"))
          {
             s->can_post = 1;
             break;
          }
--cut--
Comment 1 Petr Pisar 2013-01-08 10:08:26 EST
This is relevant part of upstream commits

commit 84677a2425eb51ed6adb46c56d4683ee37d2ac01
Author: jedsoft <jedsoft@b66dfc27-5e3b-0410-ac45-e82dab92a7d9>
Date:   Mon Sep 6 16:16:58 2010 +0000

    slrn pre1.0.0 changes 19-22
    
    19. src/version.c: %d format was used to print a long integer.
    20. src/nntplib.c: slrn user "narke" discovered that his server will
        disconnect if an attempt is made to post an empty body.  slrn does
        this after authenticating with the server to verify that posting
        is possible.  As a work-around, the response comment from the
        AUTHINFO command is parsed.
    21. src/sltcp.c: Add support for gnutls logging functions.
    22. src/chkslang.c: Fixed a sscanf format issue involving long long
        integers.

commit 68eecaf8e6bf75ede77b5a14aa04fb00e35178a9
Author: jedsoft <jedsoft@b66dfc27-5e3b-0410-ac45-e82dab92a7d9>
Date:   Tue Sep 7 09:40:13 2010 +0000

    slrn pre1.1.0 change 24: fixed logic error for change 20.
    24. src/nntplib.c: A comparison in #20 should have used != instead of
        ==.
Comment 2 RHEL Product and Program Management 2013-05-01 02:52:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Petr Pisar 2013-10-31 05:30:26 EDT
This report has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.

Note You need to log in before you can comment on or make changes to this bug.