Bug 818040 - Current release will be removed when "System Preferences" displays twice
Current release will be removed when "System Preferences" displays twice
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Eric Sammons
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-02 00:48 EDT by yu zheng
Modified: 2012-07-17 09:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:04:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2012-05-02 00:48:13 EDT
Description of problem:
After setting a release version for a system, open "System Preferences" twice will remove the current release.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.16-1.el6.x86_64
subscription-manager-0.99.16-1.el6.x86_64
python-rhsm-0.99.10-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Register and auto subscribe.
[root@unused-1-30 ~]# subscription-manager register --autosubscribe
Password: 
The system has been registered with id: 6a513205-c959-48ce-8dff-39ad60f96030 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed 
2. List available releases.
[root@unused-1-30 ~]# subscription-manager release --list
5.7
5.8
5Server
6.0
6.1
6.2
6Server
3. Set release version.
[root@unused-1-30 ~]# subscription-manager release --set=6.1
Release set to: 6.1
4. Check set release from GUI.
Open "System Preferences" dialog, release version "6.1" displays successfully.
5. Close "System Preferences" and reopen it.

Actual results:
Release version is "".

Expected results:
Release version "6.1" should display.
Comment 2 Adrian Likins 2012-05-03 09:09:17 EDT
This is fixed with a change in candlepin

commit cc54a8f1d9593d79d3648ec05b3ffc2be0a43feb
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed May 2 09:40:14 2012 -0400

    818040: rhsm release combobox doesn't reset release now
    
    Calls to updateConsumer with null releasevers in the consumer
    objects could result in the consumer release being reset
    to null because of a bad equals check.
    
    Add a .equals for Release model for Consumer compares
    
    Fixes ConsumerResourceUpdateTest.nothingChanged unittest
    failure
    
    Add test cases for above.
Comment 6 Suyuan Li 2012-05-09 06:50:55 EDT
Verifying...

Verified packages:
subscription-manager-firstboot-0.99.17-1.el6.x86_64
subscription-manager-gnome-0.99.17-1.el6.x86_64
subscription-manager-0.99.17-1.el6.x86_64
subscription-manager-debuginfo-0.99.17-1.el6.x86_64
subscription-manager-migration-0.99.17-1.el6.x86_64
python-rhsm-0.99.10-1.el6.noarch

Steps of verification:
# subscription-manager register
Username: stage_test_12
Password: 
The system has been registered with id: cd40f0ed-2c3e-43af-a61f-893d142e5130 

# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

# subscription-manager release --list
6.0
6.1
6.2
6Server

# subscription-manager release --set=6.1
Release set to: 6.1

#subscription-manager-gui
Open "System Preferences" dialog, release version "6.1" displays successfully.

Close "System Preferences" and reopen it, release version  is still empty.

Verify failed, move to ASSIGNED
Comment 8 Adrian Likins 2012-05-09 17:10:16 EDT
(In reply to comment #6)
> Verifying...

> Username: stage_test_12
> Password: 

This fix is a candlepin fix, that has not been pushed to stage yet. It's currently targetted to 0.6.3, or 0.5.4 if we need it pushed into stage. 

Should be able to test and verify this against a master candlepin.
Comment 9 Adrian Likins 2012-05-09 17:16:48 EDT
Also, stage should be getting 0.5.32 (or newer) with the fix, whenever it's updated.
Comment 13 Suyuan Li 2012-05-31 01:47:46 EDT
Verify with stage candlepin-0.5.32

Steps of verification:
# subscription-manager register
Username: stage_test_12
Password: 
The system has been registered with id: cd40f0ed-2c3e-43af-a61f-893d142e5130 

# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

# subscription-manager release --list
6.1
6.2
6Server

# subscription-manager release --set=6.2
Release set to: 6.2

#subscription-manager-gui
Open "System Preferences" dialog, release version "6.2" displays successfully.

Close "System Preferences" and reopen it, release version 6.2 is still there.

The bug is fixed, move to VERIFIED.
Comment 14 Bryan Kearney 2012-07-17 09:04:54 EDT
Marking all community bugs modified or beyong as closed.

Note You need to log in before you can comment on or make changes to this bug.