Bug 818086 - insmod softdog: Device or resource busy
insmod softdog: Device or resource busy
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
i686 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 03:47 EDT by Niklaus Wirth
Modified: 2012-05-04 09:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 09:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niklaus Wirth 2012-05-02 03:47:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.when I install skybility HA for Redhat,I cannot finish it,cos I get the messj
2.[root@root]# cat /proc/misc
223 uinput
184 microcode
130 watchdog
 57 tgt
 58 device-mapper
 59 network_throughput
 60 network_latency
 61 cpu_dma_latency
 62 crash
144 nvram
228 hpet
231 snapshot
227 mcelog
 63 vga_arbiter
[root@ahngnapp119 dev]# 
3.
  
Actual results:
[root@root]# /sbin/modprobe softdog
FATAL: Error inserting softdog (/lib/modules/2.6.32-131.0.15.el6.i686/kernel/drivers/watchdog/softdog.ko): Device or resource busy

dmesg
SoftDog: cannot register miscdev on minor=130 (err=-16

Expected results:
plz help to support the trouble,thxs!


Additional info:
Comment 2 Richard W.M. Jones 2012-05-02 04:54:01 EDT
-> kernel.

'watchdog' is a userspace program.
Comment 3 Niklaus Wirth 2012-05-02 05:41:42 EDT
 2.6.32-131.0.15.el6.i686 #1 SMP Tue May 10 15:42:28 EDT 2011 i686 i686 i386 GNU/Linux
Comment 4 Niklaus Wirth 2012-05-02 05:43:41 EDT
(In reply to comment #2)
> -> kernel.
> 
> 'watchdog' is a userspace program.

 2.6.32-131.0.15.el6.i686 #1 SMP Tue May 10 15:42:28 EDT 2011 i686 i686 i386 GNU/Linux
Comment 5 Prarit Bhargava 2012-05-03 14:54:20 EDT
It's likely because another module is using the watchdog.  Can you do a lsmod and attach it to this BZ?

Thanks,

P.
Comment 6 Niklaus Wirth 2012-05-04 01:17:46 EDT
(In reply to comment #5)
> It's likely because another module is using the watchdog.  Can you do a lsmod
> and attach it to this BZ?
> 
> Thanks,
> 
> P.

plz check it,thank u!

[root@root ~]# lsmod
Module                  Size  Used by
ext3                  116854  0 
jbd                    44278  1 ext3
sunrpc                197485  1 
cpufreq_ondemand        8486  24 
acpi_cpufreq            7320  1 
nf_conntrack_netbios_ns      885  0 
nf_conntrack_broadcast     1097  1 nf_conntrack_netbios_ns
nf_conntrack_ftp       10449  0 
ip6t_REJECT             3961  2 
nf_conntrack_ipv6       7117  9 
nf_defrag_ipv6          9847  1 nf_conntrack_ipv6
xt_state                1006  9 
nf_conntrack           66010  5 nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ftp,nf_conntrack_ipv6,xt_state
ip6table_filter         2219  1 
ip6_tables             10809  1 ip6table_filter
ipv6                  266112  71 ip6t_REJECT,nf_conntrack_ipv6,nf_defrag_ipv6
dm_mirror              11652  0 
dm_region_hash         10063  1 dm_mirror
dm_log                  8520  2 dm_mirror,dm_region_hash
uinput                  6218  0 
bnx2                   67858  0 
sg                     24778  0 
microcode              12419  0 
serio_raw               3760  0 
i2c_i801                9473  0 
i2c_core               25799  1 i2c_i801
iTCO_wdt                9644  1 
iTCO_vendor_support     2382  1 iTCO_wdt
i7core_edac            14786  0 
edac_core              36981  1 i7core_edac
ext4                  327734  3 
mbcache                 5918  2 ext3,ext4
jbd2                   73784  1 ext4
sd_mod                 34239  5 
crc_t10dif              1191  1 sd_mod
sr_mod                 14219  0 
cdrom                  34036  1 sr_mod
mptsas                 49134  4 
mptscsih               31656  1 mptsas
mptbase                86924  2 mptsas,mptscsih
scsi_transport_sas     26901  1 mptsas
qla2xxx               324527  0 
scsi_transport_fc      41015  1 qla2xxx
scsi_tgt               10035  1 scsi_transport_fc
pata_acpi               2487  0 
ata_generic             2555  0 
ata_piix               19080  0 
dm_mod                 63127  2 dm_mirror,dm_log
[root@root ~]#
Comment 7 Prarit Bhargava 2012-05-04 09:16:58 EDT
iTCO_wdt                9644  1 
iTCO_vendor_support     2382  1 iTCO_wdt

These two modules grab the watchdog device.  Unload them and you should be able to load the softdog module.

P.

Note You need to log in before you can comment on or make changes to this bug.