Bug 818088 - fail to change the permission of thin pool
fail to change the permission of thin pool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Zdenek Kabelac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 04:11 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 03:45:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-05-02 04:11:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
# lvchange -pr tsvg/pool1
lvchange  device-mapper: reload ioctl on  failed: Invalid argument
lvchange  Failed to lock pool1
lvchange  Internal error: metadata commit (or revert) missing before dropping metadata from cache.
lvchange  Internal error: metadata commit (or revert) missing before dropping metadata from cache.

2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alasdair Kergon 2012-05-02 08:59:24 EDT
The kernel target does not yet support read-only thin pools/devices (but it will soon), so this command needs to give a clean error message and stop.
Comment 2 Xiaowei Li 2012-06-15 12:59:15 EDT
*** Bug 831711 has been marked as a duplicate of this bug. ***
Comment 3 Zdenek Kabelac 2012-10-19 06:10:02 EDT
Support for lvchange -pr of thin volumes should be part of 2.02.98.
Comment 4 Xiaowei Li 2012-11-13 22:50:15 EST
verified in lvm2-2.02.98-2. a typo error in the message. please change 'yes' to 'yet' maybe

# lvchange -pr vg/pool1
  Change permissions of thin pool "pool1" not yes supported.
Comment 5 Alasdair Kergon 2012-11-14 06:18:54 EST
That typo was already fixed upstream 19th October so if it's not fixed in rawhide yet, it soon will be.  But this is an f17 bug and our focus is on rawhide/f18/rhel7 now, not f17.
Comment 6 Xiaowei Li 2013-06-18 03:45:19 EDT
closed due to comment #4

Note You need to log in before you can comment on or make changes to this bug.