Bug 818199 - Please add functionality to provision IPv6 only or IPv4 only hosts
Please add functionality to provision IPv6 only or IPv4 only hosts
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 08:37 EDT by Vadim Grinco
Modified: 2012-09-13 10:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 10:56:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vadim Grinco 2012-05-02 08:37:24 EDT
We need the ability to explicitly disable ipv6 or ipv4 on a test host. That way we can make sure that the communication will be done over v4 or v6 in a multihost set up. Also we want to know what protocol we'll be using when querying DNS, pulling packages from repositories, sending the results, etc.

Note that it's not mandatory to provision the host over ipv6 due to many limitations of PXE, and other beaker components - there will be another request for that.
Comment 1 Bill Peck 2012-05-02 09:37:19 EDT
I already have a bz open for adding ipv6 support to beah.

As far as enabling/disabling ipv6/ipv4 on a host its outside of beaker.  You pass options to anaconda noipv4 or noipv6 for installation.

if you install with noipv4 anaconda should not configure the network to use ipv4 post install either.

Note You need to log in before you can comment on or make changes to this bug.