Bug 818258 - [ipa webui] Multiple issues with Add automember rule window
[ipa webui] Multiple issues with Add automember rule window
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 11:20 EDT by Namita Soman
Modified: 2015-05-18 22:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-16 09:04:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-05-02 11:20:05 EDT
Description of problem:
When adding an automember rule:
- Cannot enter in field to search for groups

- Drop down list, do not pick any group, and click Add
   Issue - the dropdown is still there with a red bar at the back - but error is not visible. After clicking around to take away the dropdown - error indicates - Required Field

- Add a rule, and add another with same name 
   Issue - Error is auto_member_rule with name "" already exists
   Doesn't specify the name


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-12.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. add an automember rule, and follow steps above

  
Actual results:
cannot see the Required Field" error behind dropdown
when adding duplicate rule, name is not specified in error

Expected results:
see better errors

Additional info:
Comment 2 Martin Kosek 2012-05-02 11:54:12 EDT
The first issue seems rather as a small annoyance caused by user which is also
easily fixable by closing the drop down. I was informed that it would take
untrivial amount of time to fix this, so I would not force fixing this issue if
QE does not object.

The second issue is valid though, I will open an upstream ticket.
Comment 3 Martin Kosek 2012-05-02 11:56:14 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2709
Comment 8 Martin Kosek 2015-01-16 09:04:33 EST
Adding Automember rule was revised during IdM/FreeIPA 4.0 refactoring and migration to PatternFly (Bug 1108212). I revisited this dialog and and the list of group is searched and offered properly. When no group is selected, error is printed.

Note You need to log in before you can comment on or make changes to this bug.