Bug 818298 - subscription-manager release --list should not display releasever applicable to rhel-5 when only rhel-6 product is installed
subscription-manager release --list should not display releasever applicable ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-02 12:55 EDT by John Sefler
Modified: 2012-06-20 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-05-02 12:55:28 EDT
Description of problem:

Currently, the release --list command is listing valid $releasever values applicable to both rhel-5 and rhel-6.  In my opinion, the release --list command should behave similarly to available content sets from a rhel entitlement...  I think the providesTags OID (1.3.6.1.4.1.2312.9.1.##.4) on the installed products should be checked and then only the cdn listing relevant to that tag should appear in the subscription-manager release --list. 

Leaving the functionality



Version-Release number of selected component (if applicable):
[root@jsefler-63server ~]# rpm -q subscription-manager python-rhsm
subscription-manager-0.99.15-1.git.1.8ad9905.el6_2.x86_64
python-rhsm-0.99.10-1.git.0.fc556a7.el6_2.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-63server ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@jsefler-63server ~]# subscription-manager register --username stage_test_12 --auto
Password: 
The system has been registered with id: 7b5a66d4-8dde-4468-82be-c2da9f948b67 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed                        

[root@jsefler-63server ~]# subscription-manager release --list
5.7
5.8
5Server
6.0
6.1
6.2
6Server

^^^ ACTUAL RESULTS


Expected results (in my opinion):
6.0    <--- See bug 802245 for exclusion of this
6.1
6.2
6Server


Here are the providesTag in the installed 69.pem...
[root@jsefler-63server ~]# openssl x509 -text -in /etc/pki/product/69.pem | grep -A1 1.3.6.1.4.1.2312.9.1.69.4
            1.3.6.1.4.1.2312.9.1.69.4: 
                ..rhel-6,rhel-6-server
[root@jsefler-63server ~]# curl --cert /etc/pki/entitlement/5513658873020194675.pem --key /etc/pki/entitlement/5513658873020194675-key.pem -k https://cdn.redhat.com/content/dist/rhel/server/6/listing
6.0
6.1
6.2
6Server

Somehow these installed product tags rhel-6,rhel-6-server should map to the /rhel/server/6/listing and exclude the /rhel/server/5/listing.  Exactly how that algorithmic magic should happen is for development to decide.
Comment 1 John Sefler 2012-05-02 13:01:08 EDT
FIXING THIS BUG WILL HELP AVOID THIS USER SCENARIO (PYCURL ERROR)....

[root@jsefler-63server ~]# subscription-manager release --list
5.7
5.8
5Server
6.0
6.1
6.2
6Server
[root@jsefler-63server ~]# subscription-manager release --set 5Server
Release set to: 5Server
[root@jsefler-63server ~]# yum repolist available
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
https://cdn.redhat.com/content/dist/rhel/server/6/5Server/x86_64/cf-tools/1.0/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
https://cdn.redhat.com/content/dist/rhel/server/6/5Server/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
https://cdn.redhat.com/content/beta/rhel/server/6/5Server/x86_64/devtoolset/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
repolist: 0
[root@jsefler-63server ~]# 


WHEN THE USER SHOULD HAVE DONE THIS...
[root@jsefler-63server ~]# subscription-manager release --set 6Server
Release set to: 6Server
[root@jsefler-63server ~]# yum repolist available
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
rhel-6-server-cf-tools-1-rpms                                                                      | 2.5 kB     00:00     
rhel-6-server-rpms                                                                                 | 3.7 kB     00:00     
https://cdn.redhat.com/content/beta/rhel/server/6/6Server/x86_64/devtoolset/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
repolist: 0

Ooops.. EXPECTED TO DEMONSTRATE AN ERROR-FREE yum repolist available
Comment 3 William Poteat 2012-05-04 10:00:16 EDT
master commit 08f30c280c14ddbb75803ff35407a3849ab4458e
Comment 5 William Poteat 2012-05-07 08:54:46 EDT
RHEL 6.3 commit d81e878b9dcba53b211d14639e5bec3ae61c05a3
Comment 8 John Sefler 2012-05-10 19:29:42 EDT
Verifying Version...

[root@qe-blade-13 ~]# rpm -q subscription-manager
subscription-manager-0.99.17-1.el6.x86_64


[root@qe-blade-13 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@qe-blade-13 ~]# subscription-manager register --username stage_test_12 --auto
Password: 
The system has been registered with id: c81cee8a-bb56-4d0e-9deb-84e9b990f4be 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

[root@qe-blade-13 ~]# subscription-manager release --list
6.1
6.2
6.3
6Server
[root@qe-blade-13 ~]# 

Moving to VERIFIED:  The RHEL5 Y-stream releases are now excluded.
Comment 10 errata-xmlrpc 2012-06-20 08:57:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.