Bug 818356 - incorrect clock blocks installation
incorrect clock blocks installation
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On: 947533
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 16:31 EDT by luke.varnadore
Modified: 2016-04-26 16:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 07:01:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description luke.varnadore 2012-05-02 16:31:02 EDT
Description of problem:
stale hardware clock causes systemd to fsck the read only filesystem in the installer environment

Version-Release number of selected component (if applicable):
2.3.0 fc16

How reproducible:
100%

Steps to Reproduce:
1.Set hardware clock outside the fsck window
2.Boot ovirt-node-iso
3.Watch in horror as it tries to fsck a read only filesystem and then dies
  
Actual results:
Dead installer

Expected results:
Installer succeeds 

Additional info:
I used hwclock to correct the date and it installs fine.
Comment 1 Fabian Deutsch 2013-02-14 09:03:25 EST
Mike,

should we take care of this situation? The only Node specific bit I see with this problem is that fsck fails because we've got a ro rootfs.
Comment 2 Mike Burns 2013-02-14 11:23:52 EST
Do you have a proposed solution?  Do we even know if this is still an issue?
Comment 3 Fabian Deutsch 2013-04-02 12:44:19 EDT
(In reply to comment #2)
> Do you have a proposed solution?  Do we even know if this is still an issue?

I believe this issue is a generic issue related to fsck - and not to Node.
What I could think of is that fsck / systemd should take care of such a situation.

I've created an upstream bug 947533 to see what they say.
Comment 4 Fabian Deutsch 2013-04-04 07:39:34 EDT
Luke,

can you still reproduce this with 2.6.0?
I couldn't on a first try.
Comment 5 Fabian Deutsch 2013-04-09 07:01:21 EDT
No response from the reporter and I'm also not able to reproduce it therefor closig this.

Note You need to log in before you can comment on or make changes to this bug.