Bug 818397 - [RFE] Please rename subscription-manager-gnome to subscription-manager-gui
[RFE] Please rename subscription-manager-gnome to subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-02 21:05 EDT by Bryan Kearney
Modified: 2013-01-10 06:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-05-02 21:05:05 EDT
Per review with RHEL PM.
Comment 1 RHEL Product and Program Management 2012-05-02 21:07:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 James Bowes 2012-05-25 09:36:45 EDT
Fixed in 1.0.2, 1493b9a0
Comment 3 J.C. Molet 2012-06-19 11:54:31 EDT
[root@jmolet-vm0 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.4-1.git.3.1768f90.el5
subscription-manager-1.0.4-1.git.3.1768f90.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.3.1768f90.el5
subscription-manager-migration-1.0.4-1.git.3.1768f90.el5

gnome has been renamed to gui and builds as such:

+ mock -r rhel5master-i386 --resultdir /var/lib/mock/rhsm.rhel5/result/subscription-manager --rebuild /tmp/tito/rhsm.rhel5/subscription-manager/subscription-manager-1.0.4-1.git.25.90c2f77.fc14.src.rpm
INFO: mock.py version 1.1.10 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(/tmp/tito/rhsm.rhel5/subscription-manager/subscription-manager-1.0.4-1.git.25.90c2f77.fc14.src.rpm)  Config(rhel5master)
State Changed: lock buildroot
State Changed: clean
State Changed: unlock buildroot
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.10
INFO: Mock Version: 1.1.10
State Changed: running yum
State Changed: unlock buildroot
State Changed: setup
State Changed: build
INFO: Done(/tmp/tito/rhsm.rhel5/subscription-manager/subscription-manager-1.0.4-1.git.25.90c2f77.fc14.src.rpm) Config(rhel5master-i386) 4 minutes 0 seconds
INFO: Results and/or logs in: /var/lib/mock/rhsm.rhel5/result/subscription-manager
INFO: Cleaning up build root ('clean_on_success=True')
State Changed: lock buildroot
State Changed: clean
INFO: chroot (/var/lib/mock/rhel5master) unlocked and deleted
State Changed: unlock buildroot
State Changed: end
+ cd /var/lib/mock/rhsm.rhel5/result/subscription-manager
+ rm -f subscription-manager-1.0.4-1.git.25.90c2f77.el5.src.rpm subscription-manager-debuginfo-1.0.4-1.git.25.90c2f77.el5.i386.rpm
+ for FILE in '$PKG*.rpm'
++ echo subscription-manager-1.0.4-1.git.25.90c2f77.el5.i386.rpm
++ sed 's/\(\(subscription-manager\(-[a-zA-Z]*\)\?\)\)-.*/\1.rpm/'
+ ARCHIVEFILE=subscription-manager.rpm
+ mv subscription-manager-1.0.4-1.git.25.90c2f77.el5.i386.rpm /home/hudson/workspace/subscription-manager.el5/rpms/i386/subscription-manager.rpm
+ for FILE in '$PKG*.rpm'
++ echo subscription-manager-firstboot-1.0.4-1.git.25.90c2f77.el5.i386.rpm
++ sed 's/\(\(subscription-manager\(-[a-zA-Z]*\)\?\)\)-.*/\1.rpm/'
+ ARCHIVEFILE=subscription-manager-firstboot.rpm
+ mv subscription-manager-firstboot-1.0.4-1.git.25.90c2f77.el5.i386.rpm /home/hudson/workspace/subscription-manager.el5/rpms/i386/subscription-manager-firstboot.rpm
+ for FILE in '$PKG*.rpm'
++ echo subscription-manager-gui-1.0.4-1.git.25.90c2f77.el5.i386.rpm
++ sed 's/\(\(subscription-manager\(-[a-zA-Z]*\)\?\)\)-.*/\1.rpm/'
+ ARCHIVEFILE=subscription-manager-gui.rpm
+ mv subscription-manager-gui-1.0.4-1.git.25.90c2f77.el5.i386.rpm /home/hudson/workspace/subscription-manager.el5/rpms/i386/subscription-manager-gui.rpm
+ for FILE in '$PKG*.rpm'
++ echo subscription-manager-migration-1.0.4-1.git.25.90c2f77.el5.i386.rpm
++ sed 's/\(\(subscription-manager\(-[a-zA-Z]*\)\?\)\)-.*/\1.rpm/'
+ ARCHIVEFILE=subscription-manager-migration.rpm
+ mv subscription-manager-migration-1.0.4-1.git.25.90c2f77.el5.i386.rpm /home/hudson/workspace/subscription-manager.el5/rpms/i386/subscription-manager-migration.rpm



marking VERIFIED.
Comment 4 J.C. Molet 2012-06-19 11:57:10 EDT
Also note that all references to subscription-manager-gnome has been updated to subscription-manager-gui in the man page.
Comment 6 errata-xmlrpc 2013-01-07 22:52:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.