Bug 818405 - SELinux is preventing /bin/systemd-tmpfiles from 'write' accesses on the directory locks.
SELinux is preventing /bin/systemd-tmpfiles from 'write' accesses on the dire...
Status: CLOSED DUPLICATE of bug 818402
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:aeb483bac20a1be4c6ed1207efb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 21:40 EDT by Paul DeLong
Modified: 2012-05-03 03:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 03:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeLong 2012-05-02 21:40:12 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /bin/systemd-tmpfiles from 'write' accesses on the directory locks.
time:           Wed 02 May 2012 09:39:57 PM EDT

description:
:SELinux is preventing /bin/systemd-tmpfiles from 'write' accesses on the directory locks.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-tmpfiles should be allowed write access on the locks directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_tmpfiles_t:s0
:Target Context                unconfined_u:object_r:nsplugin_home_t:s0
:Target Objects                locks [ dir ]
:Source                        systemd-tmpfile
:Source Path                   /bin/systemd-tmpfiles
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-units-37-19.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1
:                              SMP Thu Mar 29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Thu 19 Apr 2012 08:24:42 PM EDT
:Last Seen                     Wed 02 May 2012 09:10:13 AM EDT
:Local ID                      786ee918-0c7f-45a3-b47d-eda2e1bf183f
:
:Raw Audit Messages
:type=AVC msg=audit(1335964213.430:8757): avc:  denied  { write } for  pid=32414 comm="systemd-tmpfile" name="locks" dev="dm-1" ino=1843882 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=unconfined_u:object_r:nsplugin_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1335964213.430:8757): arch=x86_64 syscall=unlinkat success=no exit=EACCES a0=7 a1=16634d3 a2=0 a3=6e75725f7874656e items=0 ppid=1 pid=32414 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-tmpfile exe=/bin/systemd-tmpfiles subj=system_u:system_r:systemd_tmpfiles_t:s0 key=(null)
:
:Hash: systemd-tmpfile,systemd_tmpfiles_t,nsplugin_home_t,dir,write
:
:audit2allow
:
:#============= systemd_tmpfiles_t ==============
:#!!!! The source type 'systemd_tmpfiles_t' can write to a 'dir' of the following types:
:# man_t, device_t, var_auth_t, tmp_t, usr_t, etc_t, var_t, file_t, tmpfs_t, config_home_t, lockfile, pidfile, tmpfile, sandbox_file_t, var_spool_t, httpd_cache_t, faillog_t, var_lib_t, rpm_var_lib_t, httpd_sys_rw_content_t
:
:allow systemd_tmpfiles_t nsplugin_home_t:dir write;
:
:audit2allow -R
:
:#============= systemd_tmpfiles_t ==============
:#!!!! The source type 'systemd_tmpfiles_t' can write to a 'dir' of the following types:
:# man_t, device_t, var_auth_t, tmp_t, usr_t, etc_t, var_t, file_t, tmpfs_t, config_home_t, lockfile, pidfile, tmpfile, sandbox_file_t, var_spool_t, httpd_cache_t, faillog_t, var_lib_t, rpm_var_lib_t, httpd_sys_rw_content_t
:
:allow systemd_tmpfiles_t nsplugin_home_t:dir write;
:
Comment 1 Miroslav Grepl 2012-05-03 03:43:13 EDT

*** This bug has been marked as a duplicate of bug 818402 ***

Note You need to log in before you can comment on or make changes to this bug.