Bug 818471 - cpsetup: error: no such option: -k
cpsetup: error: no such option: -k
Status: CLOSED UPSTREAM
Product: Katello
Classification: Community
Component: Installer (Show other bugs)
2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Lukas Zapletal
Garik Khachikyan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 03:51 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:09:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (36.30 KB, application/x-gzip)
2012-05-03 03:51 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-05-03 03:51:17 EDT
Created attachment 581795 [details]
katello-debug

Description of problem:
recent katello installer fails on candlepin setup (katello-configure):
---
Usage: cpsetup [options]

cpsetup: error: no such option: -k
---

Version-Release number of selected component (if applicable):
m2crypto-0.21.1.pulp-7.el6.x86_64
katello-common-0.2.34-1.git.51.6b6971b.el6.noarch
katello-selinux-0.2.4-1.git.0.b03a73e.el6.noarch
katello-configure-0.2.19-1.git.46.3c8cfc9.el6.noarch
katello-repos-testing-0.2.1-1.el6.noarch
candlepin-tomcat6-0.5.27-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-certs-tools-1.1.5-1.git.0.f153109.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-glue-pulp-0.2.34-1.git.51.6b6971b.el6.noarch
pulp-1.1.6-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
python-qpid-0.14-7.el6_2.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
katello-glue-foreman-0.2.34-1.git.51.6b6971b.el6.noarch
pulp-selinux-server-1.1.6-1.el6.noarch
candlepin-0.5.27-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
katello-cli-common-0.2.32-1.git.46.6b6971b.el6.noarch
katello-cli-0.2.32-1.git.46.6b6971b.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-common-1.1.6-1.el6.noarch
katello-glue-candlepin-0.2.34-1.git.51.6b6971b.el6.noarch
katello-0.2.34-1.git.51.6b6971b.el6.noarch
katello-repos-0.2.1-1.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-agent-1.0.3-1.git.0.cccd0b4.el6.noarch


How reproducible:
from the first attempt.

Steps to Reproduce:
1.do run katello installer 
2.
3.
  
Actual results:
fails on:
---
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120503-093919/main.log]
Creating Candlepin database user
############################################################ ... OK
Candlepin setup

  Failed, please check [/var/log/katello/katello-configure/cpsetup.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
[1;35merr: /Stage[main]/Apache2/Exec[reload-apache2]: Failed to call refresh: /etc/init.d/httpd reload returned 7 instead of one of [0] at /usr/share/katello/install/puppet/modules/apache2/manifests/init.pp:14[0m
---

Expected results:
no failure.

Additional info:
debug logs are attached:
Comment 1 Garik Khachikyan 2012-05-03 03:51:56 EDT
moved prior. up: not able to install/use katello.
Comment 2 Lukas Zapletal 2012-05-15 04:16:01 EDT
Last week I reimported repos and tagged stable, it should be working again. Please check. Putting ON_QA since this is an infrastructure issue.
Comment 3 Garik Khachikyan 2012-05-15 04:24:23 EDT
# VERIFIED

recent nightly installations proof: it works.

--
m2crypto-0.21.1.pulp-7.el6.x86_64
mod_wsgi-3.3-3.pulp.el6.x86_64
python-qpid-0.14-7.el6_2.noarch
katello-glue-candlepin-0.2.35-1.git.39.f968b3f.el6.noarch
pulp-1.0.4-1.el6.noarch
katello-repos-testing-0.2.4-1.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
katello-agent-1.0.3-1.git.0.cccd0b4.el6.noarch
candlepin-0.5.32-1.el6.noarch
pulp-common-1.0.4-1.el6.noarch
katello-common-0.2.35-1.git.39.f968b3f.el6.noarch
pulp-selinux-server-1.0.4-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-0.2.33-1.git.21.60dfa73.el6.noarch
katello-cli-tests-0.2.15-1.git.6.e9265a5.el6.noarch
katello-certs-tools-1.1.6-1.git.0.4878f30.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-glue-foreman-0.2.35-1.git.39.f968b3f.el6.noarch
katello-0.2.35-1.git.39.f968b3f.el6.noarch
katello-configure-0.2.20-1.git.23.a39fddd.el6.noarch
candlepin-tomcat6-0.5.32-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-0.2.33-1.git.21.60dfa73.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
katello-glue-pulp-0.2.35-1.git.39.f968b3f.el6.noarch
katello-selinux-0.2.4-1.git.0.b03a73e.el6.noarch
katello-repos-0.2.4-1.el6.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
--
Comment 4 Bryan Kearney 2012-07-17 09:09:26 EDT
Moving all community bugs with fixes to closed.

Note You need to log in before you can comment on or make changes to this bug.