Bug 818510 - cpdb --update seems to be dependent on internet connection for some xsd files used by liquibase
cpdb --update seems to be dependent on internet connection for some xsd files...
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devan Goodwin
Eric Sammons
:
: 818925 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 04:56 EDT by Ivan Necas
Modified: 2015-05-14 10:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Necas 2012-05-03 04:56:00 EDT
Description of problem:

I've tried to run cpdb --update and I'm getting an error (see below). A couple minutes ago the update was successful.

I've noticed that by the time of this error, I'm getting 503 when requesting http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd Service Temporarily Unavailable.

I would expect that running an update script should not be dependent on availability of some external service.


########## ERROR ############
Error running command: liquibase --driver=org.postgresql.Driver --classpath=/usr
/share/java/postgresql-jdbc.jar:/var/lib/tomcat6/webapps/candlepin/WEB-INF/class
es/ --changeLogFile=db/changelog/changelog-update.xml --url=jdbc:postgresql:cand
lepin --username=candlepin migrate
Status code: 65280
Command output: INFO 5/3/12 10:39 AM:liquibase: Successfully acquired change log
 lock
WARNING 5/3/12 10:40 AM:liquibase: schema_reference.4: Failed to read schema doc
ument 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because
 1) could not find the document; 2) the document could not be read; 3) the root 
element of the document is not <xsd:schema>.
INFO 5/3/12 10:40 AM:liquibase: Successfully released change log lock
Liquibase Update Failed: schema_reference.4: Failed to read schema document 'htt
p://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could 
not find the document; 2) the document could not be read; 3) the root element of
 the document is not <xsd:schema>.
SEVERE 5/3/12 10:40 AM:liquibase: schema_reference.4: Failed to read schema docu
ment 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 
1) could not find the document; 2) the document could not be read; 3) the root e
lement of the document is not <xsd:schema>.
liquibase.exception.ChangeLogParseException: Error parsing line 2 column 255 of 
db/changelog/changelog-update.xml: schema_reference.4: Failed to read schema doc
ument 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because
 1) could not find the document; 2) the document could not be read; 3) the root 
element of the document is not <xsd:schema>.
        at liquibase.parser.core.xml.XMLChangeLogSAXParser.parse(Unknown Source)

        at liquibase.Liquibase.update(Unknown Source)
        at liquibase.integration.commandline.Main.doMigration(Unknown Source)
        at liquibase.integration.commandline.Main.main(Unknown Source)
Caused by: org.xml.sax.SAXParseException; lineNumber: 2; columnNumber: 255; sche
ma_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/
dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the
 document could not be read; 3) the root element of the document is not <xsd:sch
ema>.

Additional info:
Comment 1 Devan Goodwin 2012-05-03 11:22:09 EDT
Looks like my rpm packaging doesn't include the XSD's in the jar, which it should. Working on a fix now.
Comment 3 Devan Goodwin 2012-05-04 07:55:16 EDT
*** Bug 818925 has been marked as a duplicate of this bug. ***
Comment 4 Bryan Kearney 2012-07-17 09:04:05 EDT
Marking all community bugs modified or beyong as closed.

Note You need to log in before you can comment on or make changes to this bug.