Bug 818514 - Failed to create app on stage server suddenly in the middle of testing
Failed to create app on stage server suddenly in the middle of testing
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 05:01 EDT by jizhao
Modified: 2015-05-14 21:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 13:47:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-05-03 05:01:28 EDT
Description of problem:
App creation on stage server always fail due to "undefined method `uid' for nil:NilClass".

Version-Release number of selected component (if applicable):
rhc-0.91.12-1.el6_2.noarch
broker-0.91.19-1.el6_2.noarch
node-0.91.5-1.el6_2.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Create an app of any cartridge
$ rhc app create -a app1 -t php-5.3 -d
2.
3.
  
Actual results:
<------------------output------------------>
Problem reported from server. Response code was 500.

DEBUG:
undefined method `uid' for nil:NilClass/usr/lib/ruby/gems/1.8/gems/gearchanger-m-collective-plugin-0.8.9/lib/gearchanger-m-collective-plugin/gearchanger/mcollective_application_container_proxy.rb:112:in `create'
/usr/lib/ruby/gems/1.8/gems/gearchanger-m-collective-plugin-0.8.9/lib/gearchanger-m-collective-plugin/gearchanger/mcollective_application_container_proxy.rb:103:in `each'
/usr/lib/ruby/gems/1.8/gems/gearchanger-m-collective-plugin-0.8.9/lib/gearchanger-m-collective-plugin/gearchanger/mcollective_application_container_proxy.rb:103:in `create'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.9.14/lib/stickshift-controller/app/models/gear.rb:29:in `create'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.9.14/lib/stickshift-controller/app/models/group_instance.rb:63:in `add_gear'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.9.14/lib/stickshift-controller/app/models/application.rb:262:in `create'

Exit Code: 1
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3

RESULT:
undefined method `uid' for nil:NilClass
<------------------------------------------->


Expected results:
App should be created successfully.

Additional info:
Comment 1 jizhao 2012-05-03 05:08:28 EDT
This issue begins to happen at about 14:48, May 3. Before that, app can be created successfully.
Comment 2 Thomas Wiest 2012-05-03 13:47:46 EDT
This was caused by an errant lock file on /etc/gshadow.lock.

-rw-------. 1 root root 0 May  3 02:40 /etc/gshadow.lock

Dates / Time are EDT.

Clearing the lock fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.