Bug 818623 - pkcon install fails when an enabled repository is unresolvable
pkcon install fails when an enabled repository is unresolvable
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 10:55 EDT by Matthew Garrett
Modified: 2013-08-01 13:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 13:05:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Garrett 2012-05-03 10:55:12 EDT
I have a repository that's only reachable when on the VPN. If it's enabled and I'm at home, installs produce an error along the lines of:

Simulating install            [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Querying                      [=========================]         
Downloading repository information[=========================]         
Fatal error: failed to find package nss-devel;3.13.4-2.fc17;x86_64;updates-testing: failed to find package: failed to load metadata for brew: failed to download repomd.xml from baseurl: failed to get valid response for http://download.lab.bos.redhat.com/rel-eng/brew/fedora/17/repodata/repomd.xml: Cannot resolve hostname


Disabling the repository gives:

Simulating install            [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Querying                      [=========================]         
Loading cache                 [=========================]         
Resolving dependencies        [=========================]         
Loading cache                 [=========================]         
Resolving dependencies        [=========================]         
Loading cache                 [=========================]         
Resolving dependencies        [=========================]         
Loading cache                 [=========================]         
Resolving dependencies        [=========================]         
Installing packages           [                         ] (0%)  
The following packages have to be installed:
 nspr-devel-4.9-2.fc17.x86_64	Development libraries for the Netscape Portable Runtime
 nss-softokn-devel-3.13.4-2.fc17.x86_64	Development libraries for Network Security Services
 nss-softokn-freebl-devel-3.13.4-2.fc17.x86_64	Header and Library files for doing development with the Freebl library for NSS
 nss-util-devel-3.13.4-2.fc17.x86_64	Development libraries for Network Security Services Utilities
 nss-devel-3.13.4-2.fc17.x86_64	Development libraries for Network Security Services
Proceed with changes? [N/y] y

and everything works.
Comment 1 Richard Hughes 2012-05-04 05:57:32 EDT
commit efe6b4c40f4254991b28aacdf594a37d562edf51
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri May 4 10:55:25 2012 +0100

    Allow the repo to be skipped if libsoup returns with 'Cannot resolve hostname'
    
    Should resolve https://bugzilla.redhat.com/show_bug.cgi?id=818623

Note, I've also added some other enums that make sense too.
Comment 3 Fedora End Of Life 2013-07-04 01:50:32 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2013-08-01 13:06:05 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.