Bug 818896 - 2 apps with lower case app name and upper case app name can be created at the same time
2 apps with lower case app name and upper case app name can be created at the...
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 06:08 EDT by jizhao
Modified: 2015-05-14 21:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 20:09:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-05-04 06:08:22 EDT
Description of problem:
Create an app with an upper case name: "APP". Create another one with an lower case name: "app" and you will get "Error communicating with DNS system." Create an app named "app" again and it will succeed. Since domain is case-insensitive, we won't be able to access "APP" any more.

Version-Release number of selected component (if applicable):
stage-2.0.10

How reproducible:
Always

Steps to Reproduce:
1.Create an app with an upper case name: "APP"
$ rhc app create -a APP -t php-5.3 -dp redhat
2.Create another app with a lower case name: "app"
$ rhc app create -a app -t php-5.3 -dp redhat
3.Create an app named "app" again
$ rhc app create -a app -t php-5.3 -dp redhat
  
Actual results:
2.app creation failed.
<----------output------------->
Problem reported from server. Response code was 500.

DEBUG:


Exit Code: 1
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
api_c: placeholder
API version:    1.1.3

RESULT:
Error communicating with DNS system.  If the problem persists please contact Red Hat support.
<----------------------------->
3.app is created successfully.

Expected results:
2. Error message should be more friendly like "app already exists" or "DNS already exists".
3. app shouldn't be created, or we won't be able to access "APP" any more.

Additional info:
Comment 1 Krishna Raman 2012-05-04 12:52:07 EDT
https://github.com/openshift/crankcase/pull/16
Comment 2 Krishna Raman 2012-05-04 16:21:27 EDT
https://github.com/openshift/crankcase/pull/17
Comment 3 Krishna Raman 2012-05-04 20:09:29 EDT
Moved to user story US1787

Note You need to log in before you can comment on or make changes to this bug.