Bug 818957 - Missing systemD unit file
Missing systemD unit file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Krempa
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 09:32 EDT by Alex Sersen
Modified: 2014-06-17 20:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:34:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Sersen 2012-05-04 09:32:20 EDT
Hi,

the script has marked your component with error 'missing systemD unit file'. Please review, comment and/or fix it.

Useful links:
http://fedoraproject.org/wiki/Features/SysVtoSystemd
http://fedoraproject.org/wiki/Features/systemd
Comment 1 Peter Krempa 2012-10-01 10:30:48 EDT
In the newest build, the systemD unit file is already generated and present in the package. 

Moving to POST.
Comment 2 yanbing du 2013-03-22 03:22:46 EDT
Test this bug on libvirt-1.0.3-1.el7.x86_64

# systemctl list-unit-files --type=service |grep libvirt
libvirt-guests.service                      disabled
libvirtd.service                            enabled 

# ls /lib/systemd/system/*.service /etc/systemd/system/*.service |grep libvirt
/lib/systemd/system/libvirtd.service
/lib/systemd/system/libvirt-guests.service

# cat /lib/systemd/system/libvirtd.service 
# NB we don't use socket activation. When libvirtd starts it will
# spawn any virtual machines registered for autostart. We want this
# to occur on every boot, regardless of whether any client connects
# to a socket. Thus socket activation doesn't have any benefit

[Unit]
Description=Virtualization daemon
Before=libvirt-guests.service
After=network.target
After=dbus.service
After=iscsid.service

[Service]
EnvironmentFile=-/etc/sysconfig/libvirtd
ExecStart=/usr/sbin/libvirtd $LIBVIRTD_ARGS
ExecReload=/bin/kill -HUP $MAINPID
KillMode=process
# Override the maximum number of opened files
#LimitNOFILE=2048

[Install]
WantedBy=multi-user.target

# systemctl reload-or-restart libvirtd.service
# echo $?
0

# systemctl status libvirtd
libvirtd.service - Virtualization daemon
	  Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled)
	  Active: active (running) since Fri 2013-03-22 14:14:37 CST; 1h 2min ago
	Main PID: 11656 (libvirtd)
	  CGroup: name=systemd:/system/libvirtd.service
		  ├─ 2771 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
		  └─11656 /usr/sbin/libvirtd


So this bug can VERIFIED.
Comment 6 Ludek Smid 2014-06-13 08:34:04 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.