Bug 819157 - pdfcrop from texlive-utils fail on certain files without meaningful error message
pdfcrop from texlive-utils fail on certain files without meaningful error mes...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-05 05:22 EDT by Petr Spacek
Modified: 2013-07-02 19:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 04:20:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failing input PDF file (2.59 KB, application/octet-stream)
2012-05-05 05:24 EDT, Petr Spacek
no flags Details
original DIA file - transformed to EPS (4.49 KB, application/octet-stream)
2012-05-05 05:25 EDT, Petr Spacek
no flags Details
input for epstopdf (4.62 KB, application/ps)
2012-05-05 05:25 EDT, Petr Spacek
no flags Details

  None (edit)
Description Petr Spacek 2012-05-05 05:22:45 EDT
Description of problem:
"pdfcrop" utility fails on attached file, no meaningful error message is produced. On other files pdfcrop works.

Version-Release number of selected component (if applicable):
texlive-utils-2007-66.fc16.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Download attached PDF file.
2. Execute pdfcrop "big-db.pdf" "db.pdf"


Actual results:
PDFCROP 1.5, 2004/06/24 - Copyright (c) 2002, 2004 by Heiko Oberdiek.
!!! Error: Cannot move `tmp-pdfcrop-21323.pdf' to `db.pdf'!


Expected results:
File "db.pdf" was produced.


Additional info:
File "big-db.pdf" was produced via these commands:
dia -e "db.eps" --filter eps "db.dia"
epstopdf "--outfile=big-db.pdf" "db.eps"

Intermediate EPS and PDF "big-db.pdf" files seems to be OK in Evince. EPS file seems to be OK also in "gv".
Comment 1 Petr Spacek 2012-05-05 05:24:15 EDT
Created attachment 582271 [details]
failing input PDF file
Comment 2 Petr Spacek 2012-05-05 05:25:09 EDT
Created attachment 582272 [details]
original DIA file - transformed to EPS
Comment 3 Petr Spacek 2012-05-05 05:25:52 EDT
Created attachment 582273 [details]
input for epstopdf
Comment 4 Jindrich Novy 2012-10-07 04:20:52 EDT
pdfcrop now works flawlessly in TeX Live 2012 in rawhide.
Comment 5 Fedora Update System 2012-10-20 01:26:51 EDT
texlive-2012-3.20121019_r28030.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2012-3.20121019_r28030.fc18

Note You need to log in before you can comment on or make changes to this bug.