Bug 819279 - ovirt-engine-backend [TEXT]: trying to destroy an active domain will give an error that the domain is unknown and not active
ovirt-engine-backend [TEXT]: trying to destroy an active domain will give an ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: 3.1.0
Assigned To: Tal Nisan
vvyazmin@redhat.com
storage
:
: 818192 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 05:11 EDT by Dafna Ron
Modified: 2016-02-10 11:38 EST (History)
10 users (show)

See Also:
Fixed In Version: SI8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (22.04 KB, application/x-xz)
2012-05-06 05:11 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-06 05:11:38 EDT
Created attachment 582409 [details]
log

Description of problem:

trying to destroy an active SD will give the following error: 

Error: Cannot destroy Storage. Storage status is unknown.
-Please check Storage Domain and retry the operation.

please change error message to include other SD states 
also, we should be able to destroy the domain in unknown state.

Version-Release number of selected component (if applicable):

si3

How reproducible:

100%

Steps to Reproduce:
1. try to destroy and active domain 
2.
3.
  
Actual results:

we get an error that storage domain is unknown 

Expected results:

we should include all states in the error

Additional info: log 

2012-05-06 11:26:17,306 WARN  [org.ovirt.engine.core.bll.storage.ForceRemoveStorageDomainCommand] (ajp--0.0.0.0-8009-3) CanDoAction of action ForceRemoveStorageDomain failed. Reasons:VAR__ACTION__DESTROY_DOMAIN,VAR__TYPE__STORAGE__DOMAIN,ACTION_TYPE_FAILED_STORAGE_DOMAIN_STATUS_ILLEGAL2
Comment 1 Tal Nisan 2012-06-11 15:42:22 EDT
http://gerrit.ovirt.org/5260
Comment 2 Tal Nisan 2012-06-13 09:57:30 EDT
Commit b05469388b690b8beb93070bbe77738637aafa25
Comment 3 vvyazmin@redhat.com 2012-06-26 10:22:24 EDT
This BUG reproduced on RHEVM 3.1 - SI7 


RHEV-M: rhevm-3.1.0-2.el6ev.noarch
VDSM: vdsm-4.9.6-17.0.el6.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMV & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
Comment 4 Tal Nisan 2012-06-26 10:24:42 EDT
You don't get the correct status in the message?
Comment 5 vvyazmin@redhat.com 2012-07-09 09:24:02 EDT
Verified on RHEVM 3.1 - SI9.1 

RHEV-M: rhevm-3.1.0-5.el6ev.noarch
VDSM: vdsm-4.9.6-17.0.el6.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMV & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
Comment 6 Allon Mureinik 2012-09-30 02:00:37 EDT
*** Bug 818192 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.