Bug 819293 - RHEVM - Backend: Events involving disks should mention disk names
RHEVM - Backend: Events involving disks should mention disk names
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.1.0
Assigned To: Tal Nisan
vvyazmin@redhat.com
storage
:
: 721241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 06:30 EDT by Daniel Paikov
Modified: 2016-02-10 11:30 EST (History)
11 users (show)

See Also:
Fixed In Version: SI10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-05-06 06:30:28 EDT
Events that involve disks should mention disk names, now that we have aliases for each disk. Events such as these (and others?) should now refer to the disks by name/alias:

User <user> moving disk to domain <domain>.
User <user> initiate removing of disk from domain <domain>.
User <user> finished to remove a disk from domain <domain>.
VM <vm> disk was plugged by <user>.
VM <vm> disk was unplugged by <user>.
Comment 1 Tal Nisan 2012-05-29 08:48:27 EDT
Fixed already for BZ #721241
https://bugzilla.redhat.com/721241
Comment 2 Ayal Baron 2012-06-14 04:21:07 EDT
*** Bug 721241 has been marked as a duplicate of this bug. ***
Comment 3 Dafna Ron 2012-06-20 04:47:02 EDT
although not listed above we still have a 'DiskAlias' instead of disk name when adding a disk
Comment 4 Tal Nisan 2012-06-20 07:57:43 EDT
http://gerrit.ovirt.org/5530
Comment 5 Dafna Ron 2012-06-25 10:36:52 EDT
not in si7:
The disk 'DiskAlias' was successfully added to VM VM1.
moving back to devel
Comment 6 Daniel Paikov 2012-07-05 08:46:52 EDT
Still reproduces on si9.1:
* Add-Disk operation of 'DiskAlias' was initiated on VM VmName by admin@internal.
* The disk 'DiskAlias' was successfully added to VM aaa.
Comment 7 Yaniv Kaul 2012-07-05 08:50:39 EDT
(In reply to comment #6)
> Still reproduces on si9.1:
> * Add-Disk operation of 'DiskAlias' was initiated on VM VmName by
> admin@internal.
> * The disk 'DiskAlias' was successfully added to VM aaa.

I'm actually getting:
"Add-Disk operation of 'spice_Disk1' was initiated on VM spice by admin@internal." so I wonder what's different between our setups. - so I don't see the 'DiskAlias' bug. I'm working with thin provisioned local storage disks.
Comment 8 Daniel Paikov 2012-07-05 09:26:12 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Still reproduces on si9.1:
> > * Add-Disk operation of 'DiskAlias' was initiated on VM VmName by
> > admin@internal.
> > * The disk 'DiskAlias' was successfully added to VM aaa.
> 
> I'm actually getting:
> "Add-Disk operation of 'spice_Disk1' was initiated on VM spice by
> admin@internal." so I wonder what's different between our setups. - so I
> don't see the 'DiskAlias' bug. I'm working with thin provisioned local
> storage disks.

What about adding new disks via the Disks tab?
Comment 9 Yaniv Kaul 2012-07-05 09:46:55 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Still reproduces on si9.1:
> > > * Add-Disk operation of 'DiskAlias' was initiated on VM VmName by
> > > admin@internal.
> > > * The disk 'DiskAlias' was successfully added to VM aaa.
> > 
> > I'm actually getting:
> > "Add-Disk operation of 'spice_Disk1' was initiated on VM spice by
> > admin@internal." so I wonder what's different between our setups. - so I
> > don't see the 'DiskAlias' bug. I'm working with thin provisioned local
> > storage disks.
> 
> What about adding new disks via the Disks tab?

"Add-Disk operation of 'newdiskAA' was initiated on VM VmName by admin@internal." (still the bug of VmName, but the disk name is OK).
Comment 10 Tal Nisan 2012-07-08 10:46:06 EDT
The disk name appears correctly for me in si9.1, the VM name appears as 'VmName' indeed when adding a floating disk since it's not added inside a VM, working to fix it now
Comment 11 Tal Nisan 2012-07-08 12:23:05 EDT
Fix for the VMName when adding a floating disk:
http://gerrit.ovirt.org/6048
Comment 12 Tal Nisan 2012-07-10 17:30:32 EDT
Fix for the VM name was fixed and merged already, abandoning my patch, fix is in
http://gerrit.ovirt.org/#/c/6078
Comment 13 vvyazmin@redhat.com 2012-07-19 09:03:21 EDT
Verified on RHEVM 3.1 - SI10

RHEV-M: rhevm-3.1.0-6.el6ev.noarch
VDSM: vdsm-4.9.6-21.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.1.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.