Bug 819316 - edit of domain while there are running tasks will cause time out for other tasks sent
edit of domain while there are running tasks will cause time out for other ta...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
high Severity low
: ---
: 3.3.0
Assigned To: Sergey Gotliv
yeylon@redhat.com
storage
:
: 996153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 11:00 EDT by Dafna Ron
Modified: 2016-04-18 02:46 EDT (History)
13 users (show)

See Also:
Fixed In Version: is14
Doc Type: Bug Fix
Doc Text:
Editing a storage domain while there were running tasks caused a timeout for other tasks. The setStorageDomainDescription now holds a shared lock instead of an exclusive one, so other tasks can run while the storage domain is being edited.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:02:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (406.46 KB, application/x-gzip)
2012-05-06 11:00 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17198 None None None Never

  None (edit)
Description Dafna Ron 2012-05-06 11:00:56 EDT
Created attachment 582464 [details]
logs

Description of problem:

I tried two actions:
1) copy/move disk + rename domain
2) copy/move disk + extend domain

it seems as if vdsm is not responding to the requests which causes backend to rollback with timeout error. 

Version-Release number of selected component (if applicable):

si3
vdsm-4.9.6-9.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. clone vm from template (preferably raw disk) 
2. try to change domain name in webadmin
3. try to extend domain
  
Actual results:

action will be sent to vdsm and eventually get time out error in webadmin. 
however, the change description action will eventually be completed and the name will be changed. 

Expected results:

we should not time out on domain changes because of one copy/clone task running. 

Additional info: logs are attached 

vdsm name change: 

Thread-202314::INFO::2012-05-06 17:40:50,836::logUtils::37::dispatcher::(wrapper) Run and protect: setStorageDomainDescription(sdUUID='99b356f1-46f4-40bf-8e1b-b86ed4be9914', des
cription='dafna-new2', options=None)


backend name change: 

2012-05-06 17:44:08,094 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetStorageDomainDescriptionVDSCommand] (ajp--0.0.0.0-8009-4) [32ae1c35] START, SetStorageDomainDescriptionVDSCommand(storagePoolId = ce13371e-d637-4901-810d-73e2fdd90496, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 99b356f1-46f4-40bf-8e1b-b86ed4be9914, description = dafna-new2), log id: 6b6ea8c8


2012-05-06 17:46:08,135 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-4) [32ae1c35] Failed in SetStorageDomainDescriptionVDS method
2012-05-06 17:46:08,136 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-4) [32ae1c35] Error code ResourceTimeout and error message IRSGenericException: IRSErrorException: Failed to SetStorageDomainDescriptionVDS, error = Resource timeout: ()



vdsm extend:

Thread-202702::INFO::2012-05-06 17:48:39,841::logUtils::37::dispatcher::(wrapper) Run and protect: extendStorageDomain(sdUUID='5a57e888-0859-47b3-8359-ea1c9d14dcda', spUUID='ce1
3371e-d637-4901-810d-73e2fdd90496', devlist=['1Dafna-Small81336292'], options=None)


2012-05-06 17:53:57,214 ERROR [org.ovirt.engine.core.bll.storage.ExtendSANStorageDomainCommand] (ajp--0.0.0.0-8009-2) [6cadcf32] Transaction rolled-back for command: org.ovirt.engine.core.bll.storage.ExtendSANStorageDomainCommand.


backend extend: 

2012-05-06 17:51:57,141 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.ExtendStorageDomainVDSCommand] (ajp--0.0.0.0-8009-2) [6cadcf32] START, ExtendStorageDomainVDSCommand(storagePoolId = ce13371e-d637-4901-810d-73e2fdd90496, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 5a57e888-0859-47b3-8359-ea1c9d14dcda, deviceList = [1Dafna-Small81336292]), log id: 1b34301d


even log: 

2012-May-06, 17:51:54
	
Storage Domain dafna-new1 was updated by vdcadmin
Time out from GUI: 

Error: A Request to the Server failed with the following Status Code: 503

GUI extend: 

Error: A Request to the Server failed with the following Status Code: 503

event log: 

2012-May-06, 17:46:08
	
Failed to update Storage Domain dafna-new2. (User: vdcadmin)
Comment 1 Ayal Baron 2012-05-06 12:02:18 EDT
is this a regression?
Comment 4 RHEL Product and Program Management 2012-07-10 03:51:51 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:55:44 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-12-14 02:52:52 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Sean Cohen 2013-04-03 07:42:48 EDT
Ayal: setStorageDomainDescription should take sharedlock and not exclusive
Comment 8 Sergey Gotliv 2013-07-22 07:19:02 EDT
I changed "setStorageDomainDescription" command to hold the shared lock instead of exclusive. "extendStorageDomain" command which had the same lock issue according to the attached log was already fixed a few month ago, see BZ876663.
Comment 9 Alissa 2013-08-13 10:33:20 EDT
*** Bug 996153 has been marked as a duplicate of this bug. ***
Comment 14 vvyazmin@redhat.com 2013-09-30 22:00:56 EDT
Verified, tested on RHEVM 3.3 - IS16 environment:

Host OS: RHEL 6.5

RHEVM:  rhevm-3.3.0-0.22.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.14-1.el6ev.noarch
VDSM:  vdsm-4.12.0-156.git6e499d6.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-27.el6.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.407.el6.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64
Comment 17 Charlie 2013-11-27 19:28:55 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 19 errata-xmlrpc 2014-01-21 11:02:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.