Bug 819410 - quick-start: tweetstream sample gets some warnings during push and does not work
quick-start: tweetstream sample gets some warnings during push and does not work
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 03:05 EDT by Meng Bo
Modified: 2015-05-14 21:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-07 03:05:14 EDT
Description of problem:
tweetstream sample gets some warnings during git push, and does not work well after that.
https://github.com/openshift/tweetstream-example

Version-Release number of selected component (if applicable):
cartridge-jbossas-7-0.92.1-1.git.73.f92efe0.el6.noarch
devenv_1757

How reproducible:
always

Steps to Reproduce:
1.follow the step to deploy jbossas tweetstream application
2.
3.
  
Actual results:
gets some warning during git push and app not work well

Expected results:
should get the tweetstream work correctly after git push.

Additional info:

<----output--->
remote: Downloaded: http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public/org/jboss/jboss-parent/6/jboss-parent-6.pom (23 KB at 111.1 KB/sec)
remote: [WARNING] 
remote: [WARNING] Some problems were encountered while building the effective model for org.richfaces.examples.tweetstream:shared:jar:1.0.0-SNAPSHOT
remote: [WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-compiler-plugin @ org.richfaces.examples.tweetstream:parent:1.0.0-SNAPSHOT, /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/pom.xml, line 330, column 12
remote: [WARNING] 
remote: [WARNING] Some problems were encountered while building the effective model for org.richfaces.examples.tweetstream:parent:pom:1.0.0-SNAPSHOT
remote: [WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-compiler-plugin @ line 330, column 12
remote: [WARNING] 
remote: [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
remote: [WARNING] 
remote: [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
remote: [WARNING] 
.
<----snip---->
.
remote: [INFO] --- maven-compiler-plugin:2.3.1:compile (default-compile) @ tweetstream ---
remote: [INFO] Compiling 15 source files to /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/target/classes
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[24,37] [deprecation] org.richfaces.application.push.EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[28,37] [deprecation] org.richfaces.application.push.SessionTopicListener in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[60,33] [deprecation] org.richfaces.application.push.SessionTopicListener in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[60,33] [deprecation] org.richfaces.application.push.SessionTopicListener in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[63,89] [deprecation] org.richfaces.application.push.EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[71,85] [deprecation] org.richfaces.application.push.EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/c062c2e808204483ba98f49524f4a140/tweet/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[84,91] [deprecation] org.richfaces.application.push.EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
<---------->
Comment 1 Dan McPherson 2012-05-07 11:50:56 EDT
Getting this in the logs:

Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,1]
Message: Unexpected element '{urn:hornetq}configuration'
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:108)
        at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69)
        at org.jboss.as.messaging.deployment.MessagingXmlParsingDeploymentUnitProcessor.deploy(MessagingXmlParsingDeploymentUnitProcessor.java:67)
        ... 6 more

2012/05/07 11:46:19,341 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "ROOT.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"ROOT.war\".PARSE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"ROOT.war\".PARSE: Failed to process phase PARSE of deployment \"ROOT.war\""}}
2012/05/07 11:46:19,518 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment ROOT.war in 105ms
2012/05/07 11:46:19,520 INFO  [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report
JBAS014777:   Services which failed to start:      service jboss.deployment.unit."ROOT.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."ROOT.war".PARSE: Failed to process phase PARSE of deployment "ROOT.war"


This seems possibly related:

https://community.jboss.org/message/635290


But disabling didn't seem to change anything.
Comment 2 Dan McPherson 2012-05-07 13:03:38 EDT
Hi Bill,

  Any idea what's going on here?
Comment 3 Bill DeCoste 2012-05-07 15:01:10 EDT
The schema for deploying destinations in AS7 is different from straight HornetQ. tweetstream-hornetq-jms.xml should look like this for an AS7 deployment:

<?xml version="1.0" encoding="UTF-8"?>
<messaging-deployment xmlns="urn:jboss:messaging-deployment:1.0">
    <hornetq-server>
        <jms-destinations>
            <jms-topic name="twitter">
                <entry name="/topic/twitter"/>
            </jms-topic>
        </jms-destinations>
    </hornetq-server>
</messaging-deployment>
Comment 4 Dan McPherson 2012-05-29 10:37:46 EDT
This quickstart used to work.  Does this mean all the current deployments of it are broken?
Comment 5 Bill DeCoste 2012-06-07 14:12:28 EDT
Corrected schema format for AS7.1 in git. Application now deploys without error.

Note You need to log in before you can comment on or make changes to this bug.